GMaven
  1. GMaven
  2. GMAVEN-91

Use GroovySystem.getVersion() instead of InvokerHelper.getVersion()

    Details

    • Type: Improvement Improvement
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.4
    • Component/s: None
    • Labels:
      None
    • Number of attachments :
      0

      Description

      Use GroovySystem.getVersion() instead of InvokerHelper.getVersion() for 1.6, 1.7, 1.8, and 1.9 runtimes.

        Activity

        Hide
        Keegan Witt added a comment -

        This will be the case for 1.7, 1.8, and 1.9. But not 1.5 or 1.6 since GroovySystem.getVersion() wasn't added until 1.6.6 (so not available in 1.5 and don't want to include for 1.6 in case users specify an older 1.6.x version).

        Show
        Keegan Witt added a comment - This will be the case for 1.7, 1.8, and 1.9. But not 1.5 or 1.6 since GroovySystem.getVersion() wasn't added until 1.6.6 (so not available in 1.5 and don't want to include for 1.6 in case users specify an older 1.6.x version).

          People

          • Assignee:
            Keegan Witt
            Reporter:
            Keegan Witt
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: