GeoTools
  1. GeoTools
  2. GEOT-778

GroupingFeatureIterator creates feature attributes in wrong order, does not respecting schema

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: app-schema plugin
    • Labels:
      None

      Description

      GroupingFeatureIterator takes care of taking a set of grouping attributes, assigning a single value to the target feature for each of them, and a set of non grouping attributes, creating multiple values of each one for the target feature.
      The problem is that the attribute order declared by the schema is not being respected.
      More specifically, the order to be respected is the order declared by the attribute mappings. That is, a series of target xpath attributes and source expressions that are evaluated in the declared order when creating the derivated feature.
      Due to that, a feature that has to be, for example, [site_name, measurement[...], location], is [site_name, location, measurement[...]]
      The effect is that non grouping attributes are appended always after the grouping ones, breaking schema adherence.

        Activity

        Gabriel Roldan added a comment -
        changed iteration strategy so attributes are added in the order declared by the attribute mappings

          People

          • Assignee:
            Gabriel Roldan
            Reporter:
            Gabriel Roldan
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: