1. GeoTools
  2. GEOT-599

WFSFeatureReader thread gets locked


    • Type: Bug Bug
    • Status: Open Open
    • Priority: Critical Critical
    • Resolution: Unresolved
    • Affects Version/s: 2.1.RC1
    • Fix Version/s: 2.7.6
    • Component/s: wfs plugin, xml
    • Labels:


      Trying to get a more or less large attribute value from a WFS (a couple megs string), a timeout exception is thrown and WFSFeatureReader::run() seems not to exit gracefully, consuming 100% CPU.
      So I'm going to work against jody's wfs-testing branch and try tu hunt this bug.

      (20:59:15) groldan: hey Jody, I need to fix a bug in WFSDataStore. I'm going to set up a jira task for it. Once I get it fixed, should I commit or attach a patch to the jira issue? (I ask 'cause I got a bit confused about the way of working on 2.1.x, plus David being the module maintainer and seem to be bussy this days, plus I need it fixed quickly)
      (20:59:25) jodygarnett: Um
      (20:59:30) jodygarnett: I probably fixed it already
      (20:59:38) jodygarnett: remember I made wfs-patch
      (20:59:47) jodygarnett: because the wfs datastore maintainer is away on holidays.
      (20:59:51) jodygarnett: (and I needed udig to work)
      (21:00:10) jodygarnett:
      (21:00:11) groldan: ah... that would be great..
      (21:00:15) groldan: let me see
      (21:00:18) jodygarnett: try that ... it is what udig runs.
      (21:00:25) jodygarnett: Fixes a number of bugs at the datastore level
      (21:00:29) jodygarnett: mostly reprojection related.
      (21:02:12) groldan: mmm... so may be its not the one I'm looking for... the point is that we're dealing with large attribute values (a couple megs strings), so WFSFeaturReader::run gets a timeout exception from which it can't survive... and the thread gets locked (consuming 100%CPU)
      (21:02:27) groldan: do you remember worked on something similar?
      (21:03:05) jodygarnett: no I don't .. interteresting problem. I had a couple goes at make a bug report and was shot down. Good luck with yours
      (21:03:34) jodygarnett: That said when I have a test case things went well.
      (21:03:41) groldan: ok, will try using your patched anyway, and in case I fix it can I commit to your branch?
      (21:04:00) jodygarnett: I wonder where the timeout is occuring ... if it is on the sax side we may be in trouble.
      (21:04:25) jodygarnett: I think there were some hints you can set to control timeout or something.
      (21:04:32) groldan: actually I'm going to debug it right now, but I'm pretty sure it's on FCBuffer
      (21:04:36) jodygarnett: Wish I could be more help.
      (21:05:07) jodygarnett: Cool. There is a known issue where a bunch of buffers hang around yeilding to each other - using 100% CPU.
      (21:05:07) groldan: yeah, but timeouts are not helping too much (well, at least I used a 30secs timeout)
      (21:05:22) groldan: the strange thing is that geoserver returns pretty fast the result
      (21:05:23) jodygarnett: I wonder if that is the problem you are describing?
      (21:05:41) groldan: It could certainly be


        Jesse Eichar added a comment -
        This still valid?
        Jesse Eichar added a comment - This still valid?


          • Assignee:
            Gabriel Roldan
            Gabriel Roldan


            • Created: