GeoTools
  1. GeoTools
  2. GEOT-4017

Asking permission to copy portion of code in the public domain

    Details

    • Type: Task Task
    • Status: Closed Closed
    • Priority: Trivial Trivial
    • Resolution: Not A Bug
    • Affects Version/s: 2.6.0
    • Fix Version/s: None
    • Component/s: coverage, metadata, referencing
    • Labels:
      None

      Description

      A few months ago, I started to provide examples of GeoAPI implementations in the public domain. The hope is to encourage GeoAPI adoption by allowing any implementors, open source or commercial, to take inspiration from this code with no obligation at all, not even obligation to acknowledge the borrowing/copying in any way. Many of those examples are derived and simplified from Geotoolkit.org code and put in the public domain by ourselves, since we wrote that code.

      However now I would like to copy some portions of code that I wrote in GeoTools 2.6 days, for example AffineTransform2D (not the full class, only portions of it). This code is copyrighted OSGeo, but OSGeo holds such copyright only on behalf of projects. I have been suggested to ask GeoTools PSC to make a motion supporting the assignment, and the GeoTools PSC chair/board liason to declare it in force on behalf of OSGeo (as an officer of the foundation). Consequently, I would like GeoTools PSC permission to copy in the public domain (no copyright holder) small portion (mostly getters and trivial methods) of following classes inherited from Geotools 2.6. I would like to stress out that the code I want to copy was written by myself.

      • From metadata module
        • DefaultGeographicBoundingBox
      • From referencing module:
        • GeneralDirectPosition
        • AbstractMathTransform
        • AffineTransform2D
        • ProjectiveTransform
        • GeneralMatrix
        • DefaultGeographicCRS
        • DefaultVerticalCRS
        • DefaultTemporalCRS
        • DefaultGeodeticDatum
        • DefaultPrimeMeridian
        • DefaultEllipsoid
      • From coverage module:
        • GeneralGridCoordinates
        • GeneralGridEnvelope
        • GeneralGridGeometry

      On the bright side for GeoTools, I'm putting in public domain much more code than what I'm asking for (wrappers around the Proj.4 C/C++ library, wrappers around the NetCDF library, OpenOffice add-in, "simple" implementation examples...), which allows GeoTools to take whatever code under their own copyright if they wish.

      Note that only the GeoAPI examples, demos and wrappers code are put in the public domain. The GeoAPI interfaces themselves and the conformance test suite still under OGC copyright with a BSD-like open source license.

        Issue Links

          Activity

          Ben Caradoc-Davies added a comment -
          I welcome this and will support any licensing change.
          Martin Desruisseaux added a comment -
          Note that GeoTools can keep the current licence if PSC wish. This request is not about changing GeoTools licence, but only to allow a derivative work to be in public domain.
          Jody Garnett added a comment -
          I am not keen on license change in general Ben as the fact of LGPL is the only thing that keeps my work contributions in scope for projects. It is cheaper to contribute back to geotools then to give the customer a copy of modified sources. Without LGPL code contributions would drastically fall.

          As for Martin's request I would like to find a way to do this for him.

          A couple of options:
          1) Take some of those files for a walk to documentation land (where we already agree that a public domain license is suitable)
          2) Make a separate branch; and make a single release from it with the modified files having both a public domain header. The seperate release would be something like "geoapi-code-examples" and would be issued in support of the GeoAPI project. Martin could take it the rest of the way.
          3) We have a procedure for donating code to GeoAPI; I could take these files for a walk and donate them to the GeoAPI project in an example(s) folder.

          Out of these options I tend to like (3) the best as I already have commit access to GeoAPI.
          Ben Caradoc-Davies added a comment -
          I agree, Jody, and I support (3). I meant a licensing change only for the copied examples; sorry for the confusion!
          Martin Desruisseaux added a comment -
          To be honest, what happened was that I ported Geotoolkit.org code to GeoAPI example modules, and more I was progressing on this task, more I realized that the amount of code derived from GeoTools 2.6 days or before (some of them from "Seagis" days, my pre-GeoTools project) was significant. At some point I felt that it was necessary to contact OSGeo or GeoTools PSC, but the work was already started. I realize that my request is a little bit late (after the fact), but it still possible for me to try to change the code in some way if this is an issue for GeoTools. However the code included in the example modules is so trivial that it would be quite difficult to write it in a different way.

          Most of the example classes which are the subject of this request are there: http://www.geoapi.org/geoapi-examples/apidocs/. Source code of the main classes having root in GeoTools or Seagis projects are:

            * http://www.geoapi.org/geoapi-examples/apidocs/src-html/org/opengis/example/referencing/AffineTransform2D.html
            * http://www.geoapi.org/geoapi-examples/apidocs/src-html/org/opengis/example/referencing/ProjectiveTransform.html
            * http://www.geoapi.org/geoapi-examples/apidocs/src-html/org/opengis/example/referencing/SimpleMatrix.html
            * http://www.geoapi.org/geoapi-examples/apidocs/src-html/org/opengis/example/geometry/SimpleDirectPosition.html
            * http://www.geoapi.org/geoapi-examples/apidocs/src-html/org/opengis/example/coverage/SimpleGridCoordinates.html
            * http://www.geoapi.org/geoapi-examples/apidocs/src-html/org/opengis/example/coverage/SimpleGridEnvelope.html

          The origin of all the above except SimpleGridCoordinates were actually written before the beginning of the GeoTools 2 project. If you look at the above source code, you will see that the parts that I ported was very straightforward parts (no WKT parsing or formatting for instance).

          Would it be an acceptable approach to just emit a statement, either on this JIRA task or on OSGeo, that you seen no concern with the above listed classes or any other class listed in the following modules?

            * http://www.geoapi.org/geoapi-examples
            * http://www.geoapi.org/geoapi-proj4
            * http://www.geoapi.org/geoapi-netcdf
            * http://www.geoapi.org/geoapi-openoffice

          Of course you are welcome to produce additional documentation pages or example code, but this effort may not be necessary for the intend of this request.
          Martin Desruisseaux added a comment -
          Is there any news about the proposed plan? Actually while the above-cited classes are very minor (I think), I would like to also push the JTS wrappers in the public domain as well. This one would be a bigger task and were created by other peoples than myself - so the GeoTools or OSGEO permission is critical in the JTS wrappers case...

          I filled a GeoAPI issue for the JTS wrappers: http://jira.codehaus.org/browse/GEO-209
          Martin Desruisseaux added a comment -
          The code that has been put in the public domain is covered by the following motion voted by the board: "The board understands that it was the intention of the GeoTools Contributor Agreement to grant the Contributor right to relicense their Submission".

          http://lists.osgeo.org/pipermail/board/2012-August/010021.html

          However this does not include the JTS wrappers, since they were written by other contributors. The JTS wrappers have not been migrated to GeoAPI. If we want to do so, they will require a new JIRA issue asking permission from the GeoTools PMC.

            People

            • Assignee:
              Jody Garnett
              Reporter:
              Martin Desruisseaux
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: