GeoTools
  1. GeoTools
  2. GEOT-3199

Image Pyramid Reader Test fails extensive testing

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Critical Critical
    • Resolution: Cannot Reproduce
    • Affects Version/s: 2.7-M2
    • Fix Version/s: None
    • Component/s: imagepyramid plugin
    • Labels:
      None
    • Environment:
      Java 1.5.0_24
      Macosx 10.6.4

      Description

      We are still failing extensive tests each time I go to release.

      Tests in error:

      • testCropLevel2(org.geotools.gce.imagepyramid.ImagePyramidReaderTest)
      • testCropLevel3(org.geotools.gce.imagepyramid.ImagePyramidReaderTest)

      Error: One factory fails for the operation "Mosaic"
      Occurs in: javax.media.jai.ThreadSafeOperationRegistry
      java.lang.reflect.InvocationTargetException
      at sun.reflect.GeneratedMethodAccessor38.invoke(Unknown Source)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:592)
      at javax.media.jai.FactoryCache.invoke(FactoryCache.java:122)
      at javax.media.jai.OperationRegistry.invokeFactory(OperationRegistry.java:1674)
      at javax.media.jai.ThreadSafeOperationRegistry.invokeFactory(ThreadSafeOperationRegistry.java:473)
      at javax.media.jai.registry.RIFRegistry.create(RIFRegistry.java:332)
      at javax.media.jai.RenderedOp.createInstance(RenderedOp.java:819)
      at javax.media.jai.RenderedOp.createRendering(RenderedOp.java:867)
      at javax.media.jai.RenderedOp.getSampleModel(RenderedOp.java:2233)
      at org.geotools.gce.imagemosaic.RasterLayerResponse.prepareCoverage(RasterLayerResponse.java:1069)
      at org.geotools.gce.imagemosaic.RasterLayerResponse.processRequest(RasterLayerResponse.java:684)
      at org.geotools.gce.imagemosaic.RasterLayerResponse.createResponse(RasterLayerResponse.java:636)
      at org.geotools.gce.imagemosaic.RasterManager.read(RasterManager.java:591)
      at org.geotools.gce.imagemosaic.ImageMosaicReader.read(ImageMosaicReader.java:569)
      at org.geotools.gce.imagepyramid.ImagePyramidReader.loadRequestedTiles(ImagePyramidReader.java:507)
      at org.geotools.gce.imagepyramid.ImagePyramidReader.loadTiles(ImagePyramidReader.java:434)
      at org.geotools.gce.imagepyramid.ImagePyramidReader.read(ImagePyramidReader.java:373)
      at org.geotools.gce.imagepyramid.ImagePyramidReaderTest.testCropLevel3(ImagePyramidReaderTest.java:726)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:592)
      at org.junit.internal.runners.TestMethod.invoke(TestMethod.java:59)
      at org.junit.internal.runners.MethodRoadie.runTestMethod(MethodRoadie.java:98)
      at org.junit.internal.runners.MethodRoadie$2.run(MethodRoadie.java:79)
      at org.junit.internal.runners.MethodRoadie.runBeforesThenTestThenAfters(MethodRoadie.java:87)
      at org.junit.internal.runners.MethodRoadie.runTest(MethodRoadie.java:77)
      at org.junit.internal.runners.MethodRoadie.run(MethodRoadie.java:42)
      at org.junit.internal.runners.JUnit4ClassRunner.invokeTestMethod(JUnit4ClassRunner.java:88)
      at org.junit.internal.runners.JUnit4ClassRunner.runMethods(JUnit4ClassRunner.java:51)
      at org.junit.internal.runners.JUnit4ClassRunner$1.run(JUnit4ClassRunner.java:44)
      at org.junit.internal.runners.ClassRoadie.runUnprotected(ClassRoadie.java:27)
      at org.junit.internal.runners.ClassRoadie.runProtected(ClassRoadie.java:37)
      at org.junit.internal.runners.JUnit4ClassRunner.run(JUnit4ClassRunner.java:42)
      at org.apache.maven.surefire.junit4.JUnit4TestSet.execute(JUnit4TestSet.java:62)
      at org.apache.maven.surefire.suite.AbstractDirectoryTestSuite.executeTestSet(AbstractDirectoryTestSuite.java:140)
      at org.apache.maven.surefire.suite.AbstractDirectoryTestSuite.execute(AbstractDirectoryTestSuite.java:127)
      at org.apache.maven.surefire.Surefire.run(Surefire.java:177)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:592)
      at org.apache.maven.surefire.booter.SurefireBooter.runSuitesInProcess(SurefireBooter.java:345)
      at org.apache.maven.surefire.booter.SurefireBooter.main(SurefireBooter.java:1009)
      Caused by: java.lang.IllegalArgumentException: Alpha images must have the same data type as the sources.
      at com.sun.media.jai.opimage.MosaicOpImage.<init>(MosaicOpImage.java:223)
      at com.sun.media.jai.opimage.MosaicRIF.create(MosaicRIF.java:39)
      ... 45 more

        Activity

        Emiliano added a comment -
        Hello Mr. Garnett,

        I'm using Java 1.5.0_24 on Mac Os X and "org.geotools.gce.imagepyramid.ImagePyramidReaderTest" is successful on my machine.
        Which version of Mac Os X are you using?

        Cheers,

        Emiliano
        Jody Garnett added a comment -
        Java 1.5.0_24 (updated issue environment description)
        Simone Giannecchini added a comment -
        Jody, how should we read your comment? Aside we have tested on win32/64, linux 32/64 and mac with java 1.5 and we have never reproduced this error!
        Jody Garnett added a comment -
        Not sure what can be done SImone; if you have a mac I don't mind sharing control of my machine using iChat (if you would like to see the error for yourself).
        I have not done anything special to this machine.

        A couple of questions:
        - what Java 1.5 you are using? You have to go to extra effort to grab an old Java 1.5 from Apple these days using the Pacifier app.
        - are you testing on trunk? or on a 2.7-M2 release of trunk

        I recently followed these instructions to get an actual Java 1.5 from apple:
        - http://chxor.chxo.com/post/183013153/installing-java-1-5-on-snow-leopard

        Before that time I had been downloading one of the Java 5 tarballs that were floating around.
        Simone Giannecchini added a comment -
        Is this still happening?
        Jody Garnett added a comment -
        I happened last release of 8.0-M4.

          People

          • Assignee:
            Simone Giannecchini
            Reporter:
            Jody Garnett
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: