GeoTools
  1. GeoTools
  2. GEOT-3003

JMapPane reset action fails to show all layers

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.6.2
    • Fix Version/s: 2.6.3, 2.7-M0
    • Component/s: swing
    • Labels:
      None

      Description

      From the user list:

      > I'm trying to load maps, which contain information about different places
      > (for example map of Italy (one shape file) and map of France (second shape
      > file). They are not displayed after JMapPane.reset() call - displayed only
      > first loaded map (Italy), second are out of the screen. It's a bug or
      > default behaviour of the JMapPane.reset()? Anyway, is there a way to show
      > all layers?

      http://n2.nabble.com/different-areas-and-JMapPane-reset-tp4773836p4773836.html

        Activity

        Michael Bedward added a comment -
        Confirmed the problem - I think its linked to how the map pane determines the full display extent
        Michael Bedward added a comment -
        The problem was that the map pane's cached fullExtent envelope was not being properly updated when the second and subsequent map layers were added. Fixed so that the reset action now works properly and the following behaviour applies:

        * If the map display is at full extent and a new layer is added the display zooms out (if necessary) to include the newly added layer.
        * If the display is not at full extent (e.g. zoomed in to existing layers or panned to one side) the display area is not changed automatically when the new layer is added.

        Changes committed to trunk (r35085) and 2.6.x branch (r35086)

          People

          • Assignee:
            Michael Bedward
            Reporter:
            Michael Bedward
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: