GeoTools
  1. GeoTools
  2. GEOT-3000

Add support for the Robinson projection

    Details

    • Type: Improvement Improvement
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.6.2
    • Fix Version/s: 2.6.3
    • Component/s: None
    • Labels:
      None

      Activity

      Andrea Aime added a comment -
      Here is GeoServer rendering a wolrd map in the Robinson projection, using this WKT CRS definition:

      PROJCS["WGS84 / Robinson", GEOGCS["WGS 84", DATUM["World Geodetic System 1984", SPHEROID["WGS 84", 6378137.0, 298.257223563, AUTHORITY["EPSG","7030"]], AUTHORITY["EPSG","6326"]], PRIMEM["Greenwich", 0.0, AUTHORITY["EPSG","8901"]], UNIT["degree", 0.017453292519943295], AUTHORITY["EPSG","4326"]], PROJECTION["Robinson"], UNIT["m", 1.0]]
      Andrea Aime added a comment -
      Fixed on 2.6.x and trunk
      Carlo Cancellieri added a comment -
      Hi Andrea,
       using the spatial reference versions of the CRS definition:

      http://spatialreference.org/ref/esri/54030/prettywkt/
      http://spatialreference.org/ref/esri/53030/prettywkt/

      --------------------------------------------------
      PROJCS["World_Robinson",
          GEOGCS["GCS_WGS_1984",
              DATUM["WGS_1984",
                  SPHEROID["WGS_1984",6378137,298.257223563]],
              PRIMEM["Greenwich",0],
              UNIT["Degree",0.017453292519943295]],
          PROJECTION["Robinson"],
          PARAMETER["False_Easting",0],
          PARAMETER["False_Northing",0],
          PARAMETER["Central_Meridian",0],
          UNIT["Meter",1],
          AUTHORITY["EPSG","54030"]]
      ------------------------------------------
      I'm getting the following error:

      Request: getServiceInfo
      23 Oct 12:45:36 ERROR [geoserver.ows] -
      org.geoserver.platform.ServiceException: Error occurred decoding the espg code EPSG:54030
      at org.geoserver.wms.map.GetMapKvpRequestReader.read(GetMapKvpRequestReader.java:186)
      at org.geoserver.wms.map.GetMapKvpRequestReader.read(GetMapKvpRequestReader.java:1)
      at org.geoserver.ows.Dispatcher.parseRequestKVP(Dispatcher.java:1412)
      at org.geoserver.ows.Dispatcher.dispatch(Dispatcher.java:622)
      at org.geoserver.ows.Dispatcher.handleRequestInternal(Dispatcher.java:263)
      at org.springframework.web.servlet.mvc.AbstractController.handleRequest(AbstractController.java:153)
      at org.springframework.web.servlet.mvc.SimpleControllerHandlerAdapter.handle(SimpleControllerHandlerAdapter.java:48)
      at org.springframework.web.servlet.DispatcherServlet.doDispatch(DispatcherServlet.java:923)
      at org.springframework.web.servlet.DispatcherServlet.doService(DispatcherServlet.java:852)
      at org.springframework.web.servlet.FrameworkServlet.processRequest(FrameworkServlet.java:882)
      at org.springframework.web.servlet.FrameworkServlet.doGet(FrameworkServlet.java:778)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:707)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:820)
      at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:487)
      at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1093)
      at org.geoserver.filters.ThreadLocalsCleanupFilter.doFilter(ThreadLocalsCleanupFilter.java:23)
      at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1084)
      at org.geoserver.filters.SpringDelegatingFilter$Chain.doFilter(SpringDelegatingFilter.java:74)
      at org.geoserver.filters.SpringDelegatingFilter.doFilter(SpringDelegatingFilter.java:45)
      at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1084)
      at org.geoserver.platform.AdvancedDispatchFilter.doFilter(AdvancedDispatchFilter.java:49)
      at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1084)
      at org.vfny.geoserver.filters.SetCharacterEncodingFilter.doFilter(SetCharacterEncodingFilter.java:109)
      at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1084)
      at org.springframework.security.web.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:311)
      at org.geoserver.security.filter.GeoServerCompositeFilter$NestedFilterChain.doFilter(GeoServerCompositeFilter.java:68)
      at org.springframework.security.web.access.intercept.FilterSecurityInterceptor.invoke(FilterSecurityInterceptor.java:116)
      at org.springframework.security.web.access.intercept.FilterSecurityInterceptor.doFilter(FilterSecurityInterceptor.java:83)
      at org.geoserver.security.filter.GeoServerCompositeFilter$NestedFilterChain.doFilter(GeoServerCompositeFilter.java:72)
      at org.geoserver.security.filter.GeoServerCompositeFilter.doFilter(GeoServerCompositeFilter.java:91)
      at org.springframework.security.web.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:323)
      at org.geoserver.security.filter.GeoServerCompositeFilter$NestedFilterChain.doFilter(GeoServerCompositeFilter.java:68)
      at org.springframework.security.web.access.ExceptionTranslationFilter.doFilter(ExceptionTranslationFilter.java:113)
      at org.geoserver.security.filter.GeoServerCompositeFilter$NestedFilterChain.doFilter(GeoServerCompositeFilter.java:72)
      at org.geoserver.security.filter.GeoServerCompositeFilter.doFilter(GeoServerCompositeFilter.java:91)
      at org.springframework.security.web.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:323)
      at org.geoserver.security.filter.GeoServerAnonymousAuthenticationFilter.doFilter(GeoServerAnonymousAuthenticationFilter.java:53)
      at org.springframework.security.web.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:323)
      at org.geoserver.security.filter.GeoServerCompositeFilter$NestedFilterChain.doFilter(GeoServerCompositeFilter.java:68)
      at org.springframework.security.web.authentication.www.BasicAuthenticationFilter.doFilter(BasicAuthenticationFilter.java:150)
      at org.geoserver.security.filter.GeoServerCompositeFilter$NestedFilterChain.doFilter(GeoServerCompositeFilter.java:72)
      at org.geoserver.security.filter.GeoServerCompositeFilter.doFilter(GeoServerCompositeFilter.java:91)
      at org.geoserver.security.filter.GeoServerBasicAuthenticationFilter.doFilter(GeoServerBasicAuthenticationFilter.java:82)
      at org.springframework.security.web.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:323)
      at org.geoserver.security.filter.GeoServerCompositeFilter$NestedFilterChain.doFilter(GeoServerCompositeFilter.java:68)
      at org.springframework.security.web.context.SecurityContextPersistenceFilter.doFilter(SecurityContextPersistenceFilter.java:87)
      at org.geoserver.security.filter.GeoServerCompositeFilter$NestedFilterChain.doFilter(GeoServerCompositeFilter.java:72)
      at org.geoserver.security.filter.GeoServerCompositeFilter.doFilter(GeoServerCompositeFilter.java:91)
      at org.springframework.security.web.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:323)
      at org.springframework.security.web.FilterChainProxy.doFilter(FilterChainProxy.java:173)
      at org.geoserver.security.GeoServerSecurityFilterChainProxy.doFilter(GeoServerSecurityFilterChainProxy.java:97)
      at org.springframework.web.filter.DelegatingFilterProxy.invokeDelegate(DelegatingFilterProxy.java:346)
      at org.springframework.web.filter.DelegatingFilterProxy.doFilter(DelegatingFilterProxy.java:259)
      at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1084)
      at org.geoserver.filters.LoggingFilter.doFilter(LoggingFilter.java:71)
      at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1084)
      at org.geoserver.filters.GZIPFilter.doFilter(GZIPFilter.java:41)
      at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1084)
      at org.geoserver.filters.SessionDebugFilter.doFilter(SessionDebugFilter.java:46)
      at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1084)
      at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:360)
      at org.mortbay.jetty.security.SecurityHandler.handle(SecurityHandler.java:216)
      at org.mortbay.jetty.servlet.SessionHandler.handle(SessionHandler.java:181)
      at org.mortbay.jetty.handler.ContextHandler.handle(ContextHandler.java:726)
      at org.mortbay.jetty.webapp.WebAppContext.handle(WebAppContext.java:405)
      at org.mortbay.jetty.handler.HandlerWrapper.handle(HandlerWrapper.java:152)
      at org.mortbay.jetty.Server.handle(Server.java:324)
      at org.mortbay.jetty.HttpConnection.handleRequest(HttpConnection.java:505)
      at org.mortbay.jetty.HttpConnection$RequestHandler.headerComplete(HttpConnection.java:828)
      at org.mortbay.jetty.HttpParser.parseNext(HttpParser.java:514)
      at org.mortbay.jetty.HttpParser.parseAvailable(HttpParser.java:211)
      at org.mortbay.jetty.HttpConnection.handle(HttpConnection.java:380)
      at org.mortbay.jetty.bio.SocketConnector$Connection.run(SocketConnector.java:228)
      at org.mortbay.thread.BoundedThreadPool$PoolThread.run(BoundedThreadPool.java:450)
      Caused by: org.opengis.referencing.FactoryException: Error in "PARAMETER": Parameter "False_Easting" was not expected.
      at org.geotools.referencing.factory.PropertyAuthorityFactory.createCoordinateReferenceSystem(PropertyAuthorityFactory.java:399)
      at org.geotools.referencing.factory.BufferedAuthorityFactory.createCoordinateReferenceSystem(BufferedAuthorityFactory.java:783)
      at org.geotools.referencing.factory.FallbackAuthorityFactory.createCoordinateReferenceSystem(FallbackAuthorityFactory.java:644)
      at org.geotools.referencing.factory.FallbackAuthorityFactory.createCoordinateReferenceSystem(FallbackAuthorityFactory.java:644)
      at org.geotools.referencing.factory.FallbackAuthorityFactory.createCoordinateReferenceSystem(FallbackAuthorityFactory.java:644)
      at org.geotools.referencing.factory.AuthorityFactoryAdapter.createCoordinateReferenceSystem(AuthorityFactoryAdapter.java:801)
      at org.geotools.referencing.factory.ThreadedAuthorityFactory.createCoordinateReferenceSystem(ThreadedAuthorityFactory.java:731)
      at org.geotools.referencing.DefaultAuthorityFactory.createCoordinateReferenceSystem(DefaultAuthorityFactory.java:179)
      at org.geotools.referencing.CRS.decode(CRS.java:489)
      at org.geotools.referencing.CRS.decode(CRS.java:417)
      at org.geoserver.wms.map.GetMapKvpRequestReader.read(GetMapKvpRequestReader.java:181)
      ... 73 more
      Caused by: java.text.ParseException: Error in "PARAMETER": Parameter "False_Easting" was not expected.
      at org.geotools.referencing.wkt.Parser.parseProjection(Parser.java:632)
      at org.geotools.referencing.wkt.Parser.parseProjCS(Parser.java:917)
      at org.geotools.referencing.wkt.Parser.parseCoordinateReferenceSystem(Parser.java:225)
      at org.geotools.referencing.wkt.Parser.parseCoordinateReferenceSystem(Parser.java:204)
      at org.geotools.referencing.factory.PropertyAuthorityFactory.createCoordinateReferenceSystem(PropertyAuthorityFactory.java:396)
      ... 83 more
      Caused by: org.opengis.parameter.ParameterNotFoundException: Parameter "False_Easting" is missing.
      at org.geotools.parameter.ParameterGroup.parameter(ParameterGroup.java:321)
      at org.geotools.referencing.wkt.Parser.parseProjection(Parser.java:617)
      ... 87 more
      23 Oct 12:45:40 INFO [geoserver.wms] -

      This is due to the False_Easting and False_Northing parameterDescriptors which are missing into your definition (since they are comparable to 0.0):

      --------------------------------------------------
      PROJCS["World_Robinson",
          GEOGCS["GCS_WGS_1984",
              DATUM["WGS_1984",
                  SPHEROID["WGS_1984",6378137,298.257223563]],
              PRIMEM["Greenwich",0],
              UNIT["Degree",0.017453292519943295]],
          PROJECTION["Robinson"],
          PARAMETER["False_Easting",0],
          PARAMETER["False_Northing",0],
          PARAMETER["Central_Meridian",0],
          UNIT["Meter",1],
          AUTHORITY["EPSG","54030"]]
      ------------------------------------------

      This improvement add support for those params:
      https://github.com/ccancellieri/geotools/commit/369551ae07e97a5ca4df0456dfaaeacb8b3b01a4

      Don't know if you want to apply it or simply ask to users to remove unsupported params.
      Cheers,
      Carlo

        People

        • Assignee:
          Andrea Aime
          Reporter:
          Andrea Aime
        • Votes:
          0 Vote for this issue
          Watchers:
          1 Start watching this issue

          Dates

          • Created:
            Updated:
            Resolved: