GeoTools
  1. GeoTools
  2. GEOT-2966

SelectionLab selects additional, incorrect features

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.6.2
    • Fix Version/s: 2.6.3, 2.7-M0
    • Component/s: None
    • Labels:
      None

      Description

      Reported on the user list. The problem is use of bbox filter testing for envelope inclusion when what we want to do in the app is test for intersection.

        Activity

        Michael Bedward added a comment -
        Fixed on trunk (r34987) and branches/2.6.x (r34988)

          People

          • Assignee:
            Michael Bedward
            Reporter:
            Michael Bedward
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: