GeoTools
  1. GeoTools
  2. GEOT-1964

JDBCDataStoreFactory should use gt2 wide default factories

    Details

    • Type: Bug Bug
    • Status: Reopened Reopened
    • Priority: Major Major
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: 2.5.9
    • Component/s: jdbc
    • Labels:
      None

      Description

      JDBCDataStoreFactory.createDataStore(...) directly instantiates the filter, geometry, featuretype and feature factory. It should use the gt2 wide defaults provided by CommonFactoryFinder instead.

        Activity

        Andrea Aime made changes -
        Field Original Value New Value
        Summary JDBCDataStoreFactory should use gt2 wise default factories JDBCDataStoreFactory should use gt2 wide default factories
        Justin Deoliveira made changes -
        Fix Version/s 2.5.0 [ 13698 ]
        Fix Version/s 2.5.1 [ 14600 ]
        Fix Version/s 2.6-M0 [ 14429 ]
        Justin Deoliveira made changes -
        Component/s data jdbc-ng [ 13503 ]
        Component/s data h2 [ 13131 ]
        Justin Deoliveira made changes -
        Fix Version/s 2.5.2 [ 14662 ]
        Fix Version/s 2.5.1 [ 14600 ]
        Justin Deoliveira made changes -
        Resolution Fixed [ 1 ]
        Status Open [ 1 ] Resolved [ 5 ]
        Andrea Aime added a comment -
        Hum... this fix actually broke the JDBC factories. The issue is, there is no implementation of GeoApi FeatureTypeFactory registered in the SPI. Did you register the one implementation we have in main and forgot to commit the spi file? Adding a unit test (at least for h2) would be a good idea.
        At the moment I'm just commenting out that line so that things start working again (I need to provide a new oracle drop and I believe Christian could use a working factory as well).
        Andrea Aime made changes -
        Status Resolved [ 5 ] Reopened [ 4 ]
        Resolution Fixed [ 1 ]
        Justin Deoliveira added a comment -
        Yeah I saw this too actually. i have changed the test setup to create the datastore via factory ( haven't yet committed ) so this path will be now tested. I am not sure why the factory is not being returned... there is a SPI entry for it under that interface. Going to just hardcode a default for now... we can keep this one open to look into the issue.
        Justin Deoliveira made changes -
        Fix Version/s 2.5.2 [ 14662 ]
        Fix Version/s 2.5.3 [ 14778 ]
        Justin Deoliveira made changes -
        Fix Version/s 2.5.4 [ 14940 ]
        Fix Version/s 2.5.3 [ 14778 ]
        Justin Deoliveira made changes -
        Fix Version/s 2.5.5 [ 15085 ]
        Fix Version/s 2.5.4 [ 14940 ]
        Andrea Aime made changes -
        Fix Version/s 2.5.6 [ 15269 ]
        Fix Version/s 2.5.5 [ 15085 ]
        Andrea Aime made changes -
        Fix Version/s 2.5.6 [ 15269 ]
        Fix Version/s 2.5.7 [ 15368 ]
        Jody Garnett made changes -
        Fix Version/s 2.5.7 [ 15368 ]
        Fix Version/s 2.5.8 [ 15543 ]
        Jody Garnett made changes -
        Fix Version/s 2.5.9 [ 15876 ]
        Fix Version/s 2.5.8 [ 15543 ]
        Jody Garnett made changes -
        Component/s jdbc [ 12180 ]
        Component/s data jdbc-ng [ 13503 ]

          People

          • Assignee:
            Justin Deoliveira
            Reporter:
            Andrea Aime
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated: