GeoTools
  1. GeoTools
  2. GEOT-1606

Allow ImageMoasic to report no data when a raster file is missing

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.5-M0
    • Fix Version/s: 2.5.8, 2.6-M3
    • Component/s: None
    • Labels:
      None

      Description

      Can we please just log a warning once (on the first attempt) and use a placeholder image for that section of the image mosaic? Handling the missing data as "no data" would go a long way here ...

      We found this by working with an image moasic shapefile for which we only had some of the rasters; took us a while to figure out what exactly was causing the problem. The workaround is to process your shapefile before handling it to the image moasic code.

        Issue Links

          Activity

          Hide
          Jody Garnett added a comment -
          I chatted to Simone on IRC and he did "something" with respect to this bug; we will need to verify before marking this as closed.
          Show
          Jody Garnett added a comment - I chatted to Simone on IRC and he did "something" with respect to this bug; we will need to verify before marking this as closed.
          Hide
          Simone Giannecchini added a comment -
          When a granule is missing the area is filled with the bkg value and a log warning is reported.
          Show
          Simone Giannecchini added a comment - When a granule is missing the area is filled with the bkg value and a log warning is reported.

            People

            • Assignee:
              Simone Giannecchini
              Reporter:
              Jody Garnett
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: