GeoServer
  1. GeoServer
  2. GEOS-733

web.xml not loaded properly in binary and windows distributions of 1.4

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 1.4.0-M0, 1.4.0-M1, 1.4.0-M2
    • Fix Version/s: 1.4.0-RC1
    • Component/s: Configuration
    • Labels:
      None
    • Number of attachments :
      0

      Description

      It appears that the web.xml file is not loaded when using the binary or windows distributions of geoserver 1.4.0-M2. (I haven't tried other distributions yet)
      Testing in eclipse does not have this issue, it has to be a real installation.

      You can test by changing the data directory or the output strategies in the web.xml file. When the server is loaded and runs, those changes are ignored.
      It defaults to "BUFFER" strategy instead of PARTIAL-BUFFER, and the data directory is the "webapps" folder, not the one specified in web.xml.

      I will need Justin's insight on this one to fix it.

        Activity

        Andrea Aime added a comment -

        Well, the parameters does not seem to be loaded when running Jetty from the IDE neither... so it does not seem a .war issue to me

        Justin Deoliveira added a comment -

        I have commited a fix for reading the service strategy stuff from the web.xml, but I cannot reproduce the GEOSERVER_DATA_DIR problem, far as I can tell it works. Can sommone verify and then reopen this issue if I am wrong.

        Andrea Aime added a comment -

        Your fixes conflicted with a change of mine, and restoring yours I noticed the bug was not fixed
        for two reasons:

        • web.xml in the web module contains "serviceStratagy", so the lookup always ends up in NULL
        • the same file has service names that are totally diffent from bean ids:
          PARTIAL-BUFFER
          BUFFER
          SPEED
          FILE

        I've fixed the typo, but I guess you have to re-check the rest

        Andrea Aime added a comment -

        Hem, sorry, throw away the second part of my comments, did not notice that stategies id matched the strings in web.xml.
        The partial buffer strategy dimension was not read from the web.xml causing an exception thought. (fix committed).

        Jason Horning added a comment -

        Hello..
        I'm a new user to geoserver and have been spending quite a bit of time lately installing and configuring 1.3.4 on windows. To date, the install has gone great and I was up and running with surprisingly little work.

        My collegue (developer) recommended that I try out RC1 because of the spring work you've been doing. When I run the windows installer and set up the featuretypes with styles like I used to do in 1.3.4. I can't get the maps to display anything.. Even after a fresh install, starting the server, and going to the adminstration page, clicking on the WMS Example fails. I'm commenting in here because if I had to guess, it has something to do with the data directory since I can't get any data loaded locally to display.


          People

          • Assignee:
            Justin Deoliveira
            Reporter:
            Brent Owens
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: