Details

    • Type: Improvement Improvement
    • Status: Closed Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.4.0-RC2
    • Component/s: None
    • Labels:
      None
    • Number of attachments :
      0

      Description

      While trying to use the binary distribution of 1.4.0-M2, the version of jetty (6.0.0rc2) wouldn't load any pages and appeard to fail to initialize fully. Reverting to a previous version of jetty (6.0.0beta16).
      This was happening on windows.
      There appears to be a 0.0 and a 0.1 release of jetty out now so we should use one of those for the next release.

        Activity

        Hide
        Andrea Aime added a comment -

        Hum, I've tried to upgrade the jetty dep and plugin to 6.0.1 and while it's working, it's also quite a lot slower than rc2, jsp compilation is visible again... what should we do....

        Show
        Andrea Aime added a comment - Hum, I've tried to upgrade the jetty dep and plugin to 6.0.1 and while it's working, it's also quite a lot slower than rc2, jsp compilation is visible again... what should we do....
        Hide
        Brent Owens added a comment -

        lets try a 5 series maybe.

        Show
        Brent Owens added a comment - lets try a 5 series maybe.
        Hide
        Andrea Aime added a comment -

        I discovered why 6.0.1 was slower... it wasn't... it's just that after a clean build the jsp need to be compiled, whilst subsequent runs reuse the compiled classes if target/work is not wiped out.
        Committed changes to 6.0.1 as of version 5177

        Show
        Andrea Aime added a comment - I discovered why 6.0.1 was slower... it wasn't... it's just that after a clean build the jsp need to be compiled, whilst subsequent runs reuse the compiled classes if target/work is not wiped out. Committed changes to 6.0.1 as of version 5177
        Hide
        Brent Owens added a comment -

        I tried 6.0.1 but it still does not load on windows. Can anyone else with a windows box try it out?

        Show
        Brent Owens added a comment - I tried 6.0.1 but it still does not load on windows. Can anyone else with a windows box try it out?
        Hide
        Andrea Aime added a comment -

        What do you mean by does not load? When running mvn jetty:run in web module, or you're deploying in a standalone jetty?
        mvn jetty:run works fine here?

        Show
        Andrea Aime added a comment - What do you mean by does not load? When running mvn jetty:run in web module, or you're deploying in a standalone jetty? mvn jetty:run works fine here?
        Hide
        Brent Owens added a comment -

        Deploying standalone.
        Using mvn jetty:run works fine but when I run it standalone it seems to load up but I get a 404 when I try to access the admin pages.

        Show
        Brent Owens added a comment - Deploying standalone. Using mvn jetty:run works fine but when I run it standalone it seems to load up but I get a 404 when I try to access the admin pages.
        Hide
        Brent Owens added a comment -

        Many configuration files were missing from etc/
        They are added back in.
        This is already correct on trunk.

        Show
        Brent Owens added a comment - Many configuration files were missing from etc/ They are added back in. This is already correct on trunk.

          People

          • Assignee:
            Brent Owens
            Reporter:
            Brent Owens
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: