GeoServer
  1. GeoServer
  2. GEOS-638

SDE to KML Translation not working

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.3.1
    • Fix Version/s: None
    • Component/s: ArcSDE
    • Labels:
      None
    • Environment:
      SUN SPARC, Solaris 5.9
    • Number of attachments :
      1

      Description

      A problem with the SDE -> KML geoserver translation, in that all requests to translate from SDE to KML (when all other translations/renderings work) result in an error being raised. Per the mailing list, it appears to be a "like a classcast exception at the root." The log of the error is attached:

      1449522 [FINE] org.vfny.geoserver.util.requests.readers.KvpRequestReader - clean request is bbox=-130,24,-66,50&request=GetMap&layers=glc:GLC.WATERSHEDS&width=800&height=400&srs=EPSG:4326&styles=green&format=application/vnd.google-earth.kml xml
      1449523 [FINE] org.vfny.geoserver.util.requests.readers.KvpRequestReader - returning parsed

      {SRS=EPSG:4326, LAYERS=glc:GLC.WATERSHEDS, BBOX=-130,24,-66,50, HEIGHT=400, REQUEST=GetMap, STYLES=green, WIDTH=800, FORMAT=application/vnd.google-earth.kml xml}

      1449524 [INFO] org.vfny.geoserver.servlets.AbstractService - Looking for configured service responses' strategy
      1449524 [INFO] org.vfny.geoserver.servlets.AbstractService - Looking for configured service strategy PARTIAL-BUFFER
      1449525 [FINE] org.vfny.geoserver.servlets.AbstractService - verifying configured strategy
      1449525 [INFO] org.vfny.geoserver.servlets.AbstractService - Using service strategy class org.vfny.geoserver.servlets.PartialBufferStrategy
      1449525 [INFO] org.vfny.geoserver.servlets.AbstractService - Set buffer size to 50
      1449526 [FINE] org.vfny.geoserver.servlets.AbstractService - reading request: bbox=-130,24,-66,50&request=GetMap&layers=glc:GLC.WATERSHEDS&width=800&height=400&srs=EPSG:4326&styles=green&format=application/vnd.google-earth.kml+xml
      1449527 [FINE] org.vfny.geoserver.global.Data - getting type glc:GLC.WATERSHEDS
      1449528 [FINE] org.geotools.styling.StyleImpl - number of fts set 1
      1449528 [FINE] org.vfny.geoserver.wms.requests.GetMapKvpReader - establishing green style for glc:GLC.WATERSHEDS
      1449530 [INFO] org.vfny.geoserver.servlets.AbstractService - handling request: org.vfny.geoserver.wms.requests.GetMapRequest@8845df8b
      1449531 [FINE] org.vfny.geoserver.servlets.AbstractService - strategy is: org.vfny.geoserver.servlets.FileStrategy@c3d9ac
      1449534 [FINE] org.vfny.geoserver.wms.responses.GetMapResponse - setting up map
      1449554 [FINE] org.vfny.geoserver.servlets.AbstractService - mime type is: application/vnd.google-earth.kml+xml
      1449556 [FINE] org.geotools.data.arcsde.ArcSDEQuery - Creating new ArcSDEQuery
      1449557 [FINE] org.geotools.data.arcsde.ArcSDEConnectionPool - com.esri.sde.sdk.client.SeConnection@fba502 now in use
      1449558 [FINE] org.geotools.data.arcsde.ArcSDEQuery - constructing new sql query with connection: com.esri.sde.sdk.client.SeConnection@fba502, propnames: [OBJECTID, AREA, PERIMETER, UNITNAME, LAKEBASIN, SUBDIV, SUBSUBDIV, SUBDIVNAME, NOMSUBDIV, HUC, BASIN, REGION, SUBREGION, ACCTUNIT, HYDROUNIT, SHAPE] sqlConstruct: com.esri.sde.sdk.client.SeSqlConstruct@14955ec
      1449558 [SEVERE] org.geotools.data.arcsde.ArcSDEDataStore - Error building SeFilter
      1449559 [FINE] org.geotools.data.arcsde.ArcSDEConnectionPool - trying to release a seconnection: com.esri.sde.sdk.client.SeConnection@fba502
      1449560 [FINE] org.geotools.data.arcsde.ArcSDEConnectionPool - com.esri.sde.sdk.client.SeConnection@fba502freed, after release used is: []
      available is [com.esri.sde.sdk.client.SeConnection@45aa2c, com.esri.sde.sdk.client.SeConnection@fba502]
      1449560 [INFO] org.vfny.geoserver.wms.responses.map.kml.EncodeKML - process failed: Problem with feature reader: Error building SeFilter
      1449561 [FINE] org.vfny.geoserver.wms.responses.GetMapResponse - asking delegate for aborting the process
      1449561 [FINE] org.vfny.geoserver.wms.responses.map.kml.KMLMapProducer - aborting KML map response
      1449562 [INFO] org.vfny.geoserver.wms.responses.map.kml.KMLMapProducer - aborting KML encoder
      1449566 [INFO] org.vfny.geoserver.servlets.AbstractService - Had an undefined error: Problem with feature reader: Error building SeFilter
      org.vfny.geoserver.wms.WmsException: Problem with feature reader: Error building SeFilter
      at org.vfny.geoserver.wms.WmsExceptionHandler.newServiceException(WmsExceptionHandler.java:64)
      at org.vfny.geoserver.servlets.AbstractService.sendError(AbstractService.java:749)
      at org.vfny.geoserver.servlets.AbstractService.doService(AbstractService.java:521)
      at org.vfny.geoserver.servlets.AbstractService.doGet(AbstractService.java:276)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:740)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
      at org.vfny.geoserver.wms.servlets.WmsDispatcher.doResponse(WmsDispatcher.java:156)
      at org.vfny.geoserver.wms.servlets.WmsDispatcher.doGet(WmsDispatcher.java:115)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:740)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
      at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:358)
      at org.mortbay.jetty.servlet.WebApplicationHandler$Chain.doFilter(WebApplicationHandler.java:342)
      at org.vfny.geoserver.filters.SetCharacterEncodingFilter.doFilter(SetCharacterEncodingFilter.java:122)
      at org.mortbay.jetty.servlet.WebApplicationHandler$Chain.doFilter(WebApplicationHandler.java:334)
      at org.mortbay.jetty.servlet.WebApplicationHandler.dispatch(WebApplicationHandler.java:286)
      at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:567)
      at org.mortbay.http.HttpContext.handle(HttpContext.java:1807)
      at org.mortbay.jetty.servlet.WebApplicationContext.handle(WebApplicationContext.java:525)
      at org.mortbay.http.HttpContext.handle(HttpContext.java:1757)
      at org.mortbay.http.HttpServer.service(HttpServer.java:879)
      at org.mortbay.http.HttpConnection.service(HttpConnection.java:790)
      at org.mortbay.http.HttpConnection.handleNext(HttpConnection.java:961)
      at org.mortbay.http.HttpConnection.handle(HttpConnection.java:807)
      at org.mortbay.http.SocketListener.handleConnection(SocketListener.java:197)
      at org.mortbay.util.ThreadedServer.handle(ThreadedServer.java:276)
      at org.mortbay.util.ThreadPool$PoolThread.run(ThreadPool.java:511)
      Caused by: org.geotools.data.DataSourceException: Problem with feature reader: Error building SeFilter
      at org.geotools.data.arcsde.ArcSDEDataStore.getFeatureReader(ArcSDEDataStore.java:598)
      at org.geotools.data.arcsde.ArcSDEDataStore.getFeatureReader(ArcSDEDataStore.java:612)
      at org.geotools.data.DefaultFeatureResults.reader(DefaultFeatureResults.java:147)
      at org.vfny.geoserver.wms.responses.map.kml.EncodeKML.writeLayers(EncodeKML.java:318)
      at org.vfny.geoserver.wms.responses.map.kml.EncodeKML.encodeKML(EncodeKML.java:128)
      at org.vfny.geoserver.wms.responses.map.kml.KMLMapProducer.writeTo(KMLMapProducer.java:93)
      at org.vfny.geoserver.wms.responses.GetMapResponse.writeTo(GetMapResponse.java:224)
      at org.vfny.geoserver.servlets.AbstractService.doService(AbstractService.java:510)
      ... 23 more
      Caused by: java.lang.RuntimeException: Error building SeFilter
      at org.geotools.filter.GeometryEncoderSDE.visit(GeometryEncoderSDE.java:214)
      at org.geotools.filter.GeometryFilterImpl.accept(GeometryFilterImpl.java:354)
      at org.geotools.filter.GeometryEncoderSDE.encode(GeometryEncoderSDE.java:148)
      at org.geotools.data.arcsde.ArcSDEQuery$FilterSet.getSpatialFilters(ArcSDEQuery.java:988)
      at org.geotools.data.arcsde.ArcSDEQuery.createSeQueryForFetch(ArcSDEQuery.java:321)
      at org.geotools.data.arcsde.ArcSDEQuery.getSeQuery(ArcSDEQuery.java:271)
      at org.geotools.data.arcsde.ArcSDEQuery.execute(ArcSDEQuery.java:643)
      at org.geotools.data.arcsde.ArcSDEDataStore.getFeatureReader(ArcSDEDataStore.java:567)
      ... 30 more
      Caused by: java.lang.ClassCastException
      at org.geotools.filter.GeometryEncoderSDE.addSpatialFilter(GeometryEncoderSDE.java:242)
      at org.geotools.filter.GeometryEncoderSDE.visit(GeometryEncoderSDE.java:190)
      ... 37 more
      1471509 [FINE] org.vfny.geoserver.util.requests.readers.KvpRequestReader - clean request is bbox=-130,24,-66,50&request=GetMap&layers=glc:GLC.WATERSHEDS&width=400&height=400&srs=EPSG:4326&styles=green&format=application/vnd.google-earth.kml xml
      1471510 [FINE] org.vfny.geoserver.util.requests.readers.KvpRequestReader - returning parsed

      {SRS=EPSG:4326, LAYERS=glc:GLC.WATERSHEDS, BBOX=-130,24,-66,50, HEIGHT=400, REQUEST=GetMap, STYLES=green, WIDTH=400, FORMAT=application/vnd.google-earth.kml xml}

      1471510 [INFO] org.vfny.geoserver.servlets.AbstractService - Looking for configured service responses' strategy
      1471510 [INFO] org.vfny.geoserver.servlets.AbstractService - Looking for configured service strategy PARTIAL-BUFFER
      1471511 [FINE] org.vfny.geoserver.servlets.AbstractService - verifying configured strategy
      1471511 [INFO] org.vfny.geoserver.servlets.AbstractService - Using service strategy class org.vfny.geoserver.servlets.PartialBufferStrategy
      1471512 [INFO] org.vfny.geoserver.servlets.AbstractService - Set buffer size to 50
      1471512 [FINE] org.vfny.geoserver.servlets.AbstractService - reading request: bbox=-130,24,-66,50&request=GetMap&layers=glc:GLC.WATERSHEDS&width=400&height=400&srs=EPSG:4326&styles=green&format=application/vnd.google-earth.kml+xml
      1471513 [FINE] org.vfny.geoserver.global.Data - getting type glc:GLC.WATERSHEDS
      1471514 [FINE] org.geotools.styling.StyleImpl - number of fts set 1
      1471515 [FINE] org.vfny.geoserver.wms.requests.GetMapKvpReader - establishing green style for glc:GLC.WATERSHEDS
      1471517 [INFO] org.vfny.geoserver.servlets.AbstractService - handling request: org.vfny.geoserver.wms.requests.GetMapRequest@8845df8b
      1471517 [FINE] org.vfny.geoserver.servlets.AbstractService - strategy is: org.vfny.geoserver.servlets.FileStrategy@1a8123b
      1471520 [FINE] org.vfny.geoserver.wms.responses.GetMapResponse - setting up map
      1471537 [FINE] org.vfny.geoserver.servlets.AbstractService - mime type is: application/vnd.google-earth.kml+xml
      1471539 [FINE] org.geotools.data.arcsde.ArcSDEQuery - Creating new ArcSDEQuery
      1471539 [FINE] org.geotools.data.arcsde.ArcSDEConnectionPool - com.esri.sde.sdk.client.SeConnection@45aa2c now in use
      1471540 [FINE] org.geotools.data.arcsde.ArcSDEQuery - constructing new sql query with connection: com.esri.sde.sdk.client.SeConnection@45aa2c, propnames: [OBJECTID, AREA, PERIMETER, UNITNAME, LAKEBASIN, SUBDIV, SUBSUBDIV, SUBDIVNAME, NOMSUBDIV, HUC, BASIN, REGION, SUBREGION, ACCTUNIT, HYDROUNIT, SHAPE] sqlConstruct: com.esri.sde.sdk.client.SeSqlConstruct@861a09
      1471541 [SEVERE] org.geotools.data.arcsde.ArcSDEDataStore - Error building SeFilter
      1471542 [FINE] org.geotools.data.arcsde.ArcSDEConnectionPool - trying to release a seconnection: com.esri.sde.sdk.client.SeConnection@45aa2c
      1471542 [FINE] org.geotools.data.arcsde.ArcSDEConnectionPool - com.esri.sde.sdk.client.SeConnection@45aa2cfreed, after release used is: []
      available is [com.esri.sde.sdk.client.SeConnection@fba502, com.esri.sde.sdk.client.SeConnection@45aa2c]
      1471543 [INFO] org.vfny.geoserver.wms.responses.map.kml.EncodeKML - process failed: Problem with feature reader: Error building SeFilter
      1471543 [FINE] org.vfny.geoserver.wms.responses.GetMapResponse - asking delegate for aborting the process
      1471544 [FINE] org.vfny.geoserver.wms.responses.map.kml.KMLMapProducer - aborting KML map response
      1471544 [INFO] org.vfny.geoserver.wms.responses.map.kml.KMLMapProducer - aborting KML encoder
      1471549 [INFO] org.vfny.geoserver.servlets.AbstractService - Had an undefined error: Problem with feature reader: Error building SeFilter
      org.vfny.geoserver.wms.WmsException: Problem with feature reader: Error building SeFilter
      at org.vfny.geoserver.wms.WmsExceptionHandler.newServiceException(WmsExceptionHandler.java:64)
      at org.vfny.geoserver.servlets.AbstractService.sendError(AbstractService.java:749)
      at org.vfny.geoserver.servlets.AbstractService.doService(AbstractService.java:521)
      at org.vfny.geoserver.servlets.AbstractService.doGet(AbstractService.java:276)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:740)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
      at org.vfny.geoserver.wms.servlets.WmsDispatcher.doResponse(WmsDispatcher.java:156)
      at org.vfny.geoserver.wms.servlets.WmsDispatcher.doGet(WmsDispatcher.java:115)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:740)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
      at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:358)
      at org.mortbay.jetty.servlet.WebApplicationHandler$Chain.doFilter(WebApplicationHandler.java:342)
      at org.vfny.geoserver.filters.SetCharacterEncodingFilter.doFilter(SetCharacterEncodingFilter.java:122)
      at org.mortbay.jetty.servlet.WebApplicationHandler$Chain.doFilter(WebApplicationHandler.java:334)
      at org.mortbay.jetty.servlet.WebApplicationHandler.dispatch(WebApplicationHandler.java:286)
      at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:567)
      at org.mortbay.http.HttpContext.handle(HttpContext.java:1807)
      at org.mortbay.jetty.servlet.WebApplicationContext.handle(WebApplicationContext.java:525)
      at org.mortbay.http.HttpContext.handle(HttpContext.java:1757)
      at org.mortbay.http.HttpServer.service(HttpServer.java:879)
      at org.mortbay.http.HttpConnection.service(HttpConnection.java:790)
      at org.mortbay.http.HttpConnection.handleNext(HttpConnection.java:961)
      at org.mortbay.http.HttpConnection.handle(HttpConnection.java:807)
      at org.mortbay.http.SocketListener.handleConnection(SocketListener.java:197)
      at org.mortbay.util.ThreadedServer.handle(ThreadedServer.java:276)
      at org.mortbay.util.ThreadPool$PoolThread.run(ThreadPool.java:511)
      Caused by: org.geotools.data.DataSourceException: Problem with feature reader: Error building SeFilter
      at org.geotools.data.arcsde.ArcSDEDataStore.getFeatureReader(ArcSDEDataStore.java:598)
      at org.geotools.data.arcsde.ArcSDEDataStore.getFeatureReader(ArcSDEDataStore.java:612)
      at org.geotools.data.DefaultFeatureResults.reader(DefaultFeatureResults.java:147)
      at org.vfny.geoserver.wms.responses.map.kml.EncodeKML.writeLayers(EncodeKML.java:318)
      at org.vfny.geoserver.wms.responses.map.kml.EncodeKML.encodeKML(EncodeKML.java:128)
      at org.vfny.geoserver.wms.responses.map.kml.KMLMapProducer.writeTo(KMLMapProducer.java:93)
      at org.vfny.geoserver.wms.responses.GetMapResponse.writeTo(GetMapResponse.java:224)
      at org.vfny.geoserver.servlets.AbstractService.doService(AbstractService.java:510)
      ... 23 more
      Caused by: java.lang.RuntimeException: Error building SeFilter
      at org.geotools.filter.GeometryEncoderSDE.visit(GeometryEncoderSDE.java:214)
      at org.geotools.filter.GeometryFilterImpl.accept(GeometryFilterImpl.java:354)
      at org.geotools.filter.GeometryEncoderSDE.encode(GeometryEncoderSDE.java:148)
      at org.geotools.data.arcsde.ArcSDEQuery$FilterSet.getSpatialFilters(ArcSDEQuery.java:988)
      at org.geotools.data.arcsde.ArcSDEQuery.createSeQueryForFetch(ArcSDEQuery.java:321)
      at org.geotools.data.arcsde.ArcSDEQuery.getSeQuery(ArcSDEQuery.java:271)
      at org.geotools.data.arcsde.ArcSDEQuery.execute(ArcSDEQuery.java:643)
      at org.geotools.data.arcsde.ArcSDEDataStore.getFeatureReader(ArcSDEDataStore.java:567)
      ... 30 more
      Caused by: java.lang.ClassCastException
      at org.geotools.filter.GeometryEncoderSDE.addSpatialFilter(GeometryEncoderSDE.java:242)
      at org.geotools.filter.GeometryEncoderSDE.visit(GeometryEncoderSDE.java:190)
      ... 37 more

        Activity

        Chris Holmes added a comment -

        Oh, I already fixed that, but hasn't made it out in a release yet. Attaching the patched jar here. I'll put out a release of it soon.

        Chris Holmes added a comment -

        Patched jar should work, let me know if there's more issues.


          People

          • Assignee:
            dblasby
            Reporter:
            Pete G
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: