GeoServer
  1. GeoServer
  2. GEOS-628

GetFeatureResults.addFeatures() enforces equality of type name between feature and meta

    Details

    • Type: Improvement Improvement
    • Status: Closed Closed
    • Priority: Minor Minor
    • Resolution: Cannot Reproduce
    • Affects Version/s: 1.3.2
    • Fix Version/s: 1.4.0-RC2
    • Component/s: WFS
    • Labels:
      None
    • Environment:
      OS X, Java 1.5
    • Number of attachments :
      0

      Description

      In org.vfny.geoserver.wfs.responses.GetFeatureResults.addFeatures(), an exception is thrown if this test is false:

      features.getSchema().getTypeName().equals(meta.getFeatureType().getTypeName())

      This breaks cascaded WFS requests (using WFSDataStore) since the feature type name will be qualified with a namespace (e.g. foo:tasmania_roads) while the FeatureTypeInfo type name will not be qualified (e.g., tasmania_roads).

      I am not sure if this was the most logical place to make a change, but commenting out this test permitted my cascaded WFS GetFeature requests to succeed.

        Issue Links

          Activity

          Chris Holmes added a comment -

          Cascading WFS, which should get in to some geoserver core, and WFS datastore. You can cascade one copy of geoserver in to another, or put it remote on geo.openplans.org or sigma.openplans.org (bug me and I'll get you logins)

          Chris Holmes added a comment -

          We probably should not just comment this out. But we can check for the qualified type name and the unqualified typename.

          Andrea Aime added a comment -

          I can't reproduce the problem neither cascading to sigma (geoserver instance) neither to the DMSolutions WFS demo, that does not have namspace prefixes... maybe the issue was introduced by other changes Ryan performed to try and make cascading work?

          Andrea Aime added a comment -

          This issue has been resolved for one month or more without complaints. Closing it.


            People

            • Assignee:
              Andrea Aime
              Reporter:
              Ryan Hofschneider
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: