Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Won't Fix
    • Affects Version/s: 1.3.0 RC6
    • Fix Version/s: 1.3.0 PR1
    • Component/s: Configuration
    • Labels:
      None
    • Environment:
    • Number of attachments :
      0

      Description

      I tried to get GeoServer running on Mandriva 2006 Linux, while menus etc appear,
      all demos fails. I suspect that JAI is the cause. Both 1.3.0-RC6 and 1.3.0-RC7 fail.
      Is the java-1.4.2-gcj probably incompatible with JAI?
      WFS GeoCapabilities seem to work.
      WMS does not:
      <?xml version="1.0" encoding="UTF-8" standalone="no" ?><!DOCTYPE ServiceExceptionReport SYSTEM "http://localhost:8080/geoserver/schemas//wms/1.1.1/WMS_exception_1_1_1.dtd"> <ServiceExceptionReport version="1.1.1"> <ServiceException code="">null</ServiceException> </ServiceExceptionReport>

      And also the most wanted WFS-T demo do not (zoom icons etc are there but not the map).

      Some details:

      A) GeoServer Administration
      Administration of running GeoServer application
      This Administration page is currently at the idea stage, it is intended to show the runtime status (and allow interaction with) the running GeoSever application.
      Locks: 0
      Connections: 0
      Memory: 9412K
      Version of JVM: Free Software Foundation, Inc. : 1.4.2
      JAI is available: true

      B) GeoServer Configuration
      Configuration of GeoServer application
      tasmania_water_bodies:tasmania_water_bodies
      DS_poly_landmarks:poly_landmarks
      DS_giant_polygon:giant_polygon
      DS_poi:poi
      states_shapefile:states
      tasmania_cities:tasmania_cities
      DS_tiger_roads:tiger_roads
      tasmania_state_boundaries:tasmania_state_boundaries
      tasmania_roads:tasmania_roads
      java.util.NoSuchElementException: No datastore found capable of managing DataStoreConfig[namespace=topp, enabled=false, abstract=null, connection parameters=

      {url=file:/usr/share/tomcat5/webapps/geoserver/data/featureTypes/tasmania_water_bodies/tasmania_water_bodies.shp, namespace=http://www.openplans.org/topp}

      ]
      java.util.NoSuchElementException: No datastore found capable of managing DataStoreConfig[namespace=tiger, enabled=false, abstract=null, connection parameters=

      {url=file:/usr/share/tomcat5/webapps/geoserver/data/demo/popup_map/data/poly_landmarks.shp, namespace=http://www.census.gov}

      ]
      java.util.NoSuchElementException: No datastore found capable of managing DataStoreConfig[namespace=tiger, enabled=false, abstract=null, connection parameters=

      {url=file:/usr/share/tomcat5/webapps/geoserver/data/demo/popup_map/data/giant_polygon.shp, namespace=http://www.census.gov}

      ]
      java.util.NoSuchElementException: No datastore found capable of managing DataStoreConfig[namespace=tiger, enabled=false, abstract=null, connection parameters=

      {url=file:/usr/share/tomcat5/webapps/geoserver/data/demo/popup_map/data/poi.shp, namespace=http://www.census.gov}

      ]
      java.util.NoSuchElementException: No datastore found capable of managing DataStoreConfig[namespace=topp, enabled=false, abstract=null, connection parameters=

      {url=file:/usr/share/tomcat5/webapps/geoserver/data/featureTypes/states/states.shp, namespace=http://www.openplans.org/topp}

      ]
      java.util.NoSuchElementException: No datastore found capable of managing DataStoreConfig[namespace=topp, enabled=false, abstract=null, connection parameters=

      {url=file:/usr/share/tomcat5/webapps/geoserver/data/featureTypes/tasmania_cities/tasmania_cities.shp, namespace=http://www.openplans.org/topp}

      ]
      java.util.NoSuchElementException: No datastore found capable of managing DataStoreConfig[namespace=tiger, enabled=false, abstract=null, connection parameters=

      {url=file:/usr/share/tomcat5/webapps/geoserver/data/demo/popup_map/data/tiger_roads.shp, namespace=http://www.census.gov}

      ]
      java.util.NoSuchElementException: No datastore found capable of managing DataStoreConfig[namespace=topp, enabled=false, abstract=null, connection parameters=

      {url=file:/usr/share/tomcat5/webapps/geoserver/data/featureTypes/tasmania_state_boundaries/tasmania_state_boundaries.shp, namespace=http://www.openplans.org/topp}

      ]
      java.util.NoSuchElementException: No datastore found capable of managing DataStoreConfig[namespace=topp, enabled=false, abstract=null, connection parameters=

      {url=file:/usr/share/tomcat5/webapps/geoserver/data/featureTypes/tasmania_roads/tasmania_roads.shp, namespace=http://www.openplans.org/topp}

      ]

      Help is appreciated
      thanks

      Markus

        Activity

        Chris Holmes added a comment -

        Scheduling this for RC8. Would be very good to have it in order, since we should be working with JAI, with no additional downloads. Or at least have a FAQ entry pointing at the right thing to do with gcj if that's the problem.

        Brent Owens added a comment -

        This is a user configuration error, not a bug. The datastores appear broken in your example, this would cause no maps to be rendered.

        Markus Neteler added a comment -

        Brent,

        sorry, I don't understand why this should be my error.
        I have downloaded the WAR file from your Website and then
        run
        http://localhost:8080/geoserver/wfs/GetCapabilities
        which worked.
        Then

        1. configuration (takes time to load the first time)
          http://localhost:8080/geoserver/
        2. -> configuration
        3. -> admin
        4. To interact with the configuration system you will need to login with the
        5. user name admin and the password geoserver. You can change the password
        6. at Server->Config->Password.
            1. ... takes time....

        I have tried a couple of ours with RC6 and RC7 (geoserver-1.3.0-RC6-war.zip,
        geoserver-1.3.0-RC7-war.zip).

        How can the datastores be broken if I simply use the WAR file from
        your web site?

        Thanks

        Markus

        Markus Neteler added a comment -

        Hi Chris,

        is there any hope? My course takes place in 3 days...
        Too bad that I cannot get geoserver running.

        Markus

        Andrea Aime added a comment -

        These issue has been in resolved state for at least one month (quite a bit, a lot more than one month). Batch transitioning them to closed state


          People

          • Assignee:
            Brent Owens
            Reporter:
            Markus Neteler
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: