GeoServer
  1. GeoServer
  2. GEOS-4076

GWC configuration does not produce WMSC Capabilities with VendorSpecificCapabilities

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.0.2
    • Fix Version/s: 2.1.0
    • Component/s: GWC
    • Labels:
      None
    • Number of attachments :
      1

      Description

      I am a bit sad performing my uDig 1.2.0 release and being unable to verify it works against GeoServer 2.0.2.

      The capabilities document listed by: http://localhost:8080/geoserver/gwc

      The link is correct:

      However the result does not include the required VendorSpecificCapabilities describing the tileset (ie it is not a WMS-C service description and thus cannot be used).

      The required section is outlined here http://wiki.osgeo.org/wiki/WMS_Tiling_Client_Recommendation

      <WMT_MS_Capabilities>
        ...
        <VendorSpecificCapabilities>
          <TileSet>
            <SRS>EPSG:4326</SRS>
            <BoundingBox srs="EPSG:4326" minx="-180" miny="-90" maxx="180" maxy="90" />
            <Resolutions>0.703125 0.3515625 0.17578125 0.087890625 0.04394531250</Resolutions>
            <Width>256</Width>
            <Height>256</Height>
            <Format>image/png</Format>
            <Layers>coastline</Layers>
            <Styles></Styles>
          </TileSet>
          <TileSet>
            <SRS>OSGEO:41001</SRS>
            <BoundingBox srs="OSGEO:41001" minx="-20037508.34" miny="-20037508.34" 
                                           maxx="20037508.34"  maxy="20037508.34" />
            <Resolutions>
               156543.03 78271.52 39135.76 19567.88 9783.94 4891.97 
            </Resolutions>
            <Width>256</Width>
            <Height>256</Height>
            <Format>image/png</Format>
            <Layers>coastline</Layers>
            <Styles></Styles>
          </TileSet>
         </VendorSpecificCapabilities>
         ...
      </WMT_MS_Capabilities>
      

      I have attached the produced capabilities document for your reference.

      1. wms
        14 kB
        Jody Garnett

        Issue Links

          Activity

          Arne Kepp added a comment -

          "Unable to verify that it works"... such a diplomat

          Have you checked the file manually? I've downloaded 2.0.2(bin) from Sourceforge, and I've checked http://demo.opengeo.org/geoserver/gwc/service/wms?request=getcapabilities&tiled=true

          In both cases it looks ok at first glance, but I haven't thrown a parser at it.

          Jody Garnett added a comment -

          was not meaning to be diplomatic; I was just going through my release process and failing the verify step :-P

          I will test http://demo.opengeo.org/geoserver/gwc/service/wms?request=getcapabilities&tiled=true now.

          I can however say that my usual test server is not working:

          I will add you demo server to my test page (http://udig.refractions.net/confluence/display/DATA/Home)

          Jody Garnett added a comment -

          Yeah that server fails as well; have a look at the capabilies document produced it does not have any WMS-C stuff.

          Arne Kepp added a comment -

          I no longer exert any influence on those servers, and sigma is almost certainly outdated anyway.

          But the demo.opengeo.org link you repeat above positively contains the WMS-C stuff. I've downloaded it several times.

          What seems to be wrong with that document is that the additional DTD elements are not defined in the header. This was fixed many months ago (no release since then), and will hopefully fix itself the next time demo.opengeo.org gets updated to a nightly build.

          Sidenote: How can I get uDig to produce some debug output, there must be some hint why it fails to load?

          Jody Garnett added a comment -

          I can confirm as well; I will test the demo server url again and see what the issue is.

          Jody Garnett added a comment -

          Hi Arne; I am writing a test case now to parse the demo server output. The parsing tech is driven by the WMS-C Schema so if anything is out of alignment it will break.

          I will step through and see if I can tell you where it is having trouble.

          Gabriel Roldan added a comment -

          It looks to me like this is fixed since a long time ago, or at least I couldn't find a culprit on the gwc commits list. The closer I got is this one but it doesn't look related at all.

          demo.opengeo.org's geoserver is really old though. Could you test against any 2.1/2.2.x geoserver?

          I'm closing the issue meanwhile anyways cause it really seems to work just fine.

          Jody Garnett added a comment -

          what server would you recommend? We need one for your demo data page.

          Gabriel Roldan added a comment -

          Hi Jody, demo.opengeo.org/geoserver was just upgraded and it seems to be working fine. So feel free to use that one: http://demo.opengeo.org/geoserver/gwc/service/wms?SERVICE=WMS&VERSION=1.1.1&REQUEST=getcapabilities&TILED=true


            People

            • Assignee:
              Gabriel Roldan
              Reporter:
              Jody Garnett
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: