GeoServer
  1. GeoServer
  2. GEOS-4035

Some GWC tests fail for clean install Rev 14530

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Minor Minor
    • Resolution: Cannot Reproduce
    • Affects Version/s: 2.0.x
    • Fix Version/s: None
    • Component/s: GWC
    • Labels:
      None
    • Environment:
      mvn --version
      Maven version: 2.0.9
      Java version: 1.6.0_17
      OS name: "linux" version: "2.6.32.14-127.fc12.x86_64" arch: "amd64" Family: "unix"
    • Number of attachments :
      5

      Description

      Tests fail for mvn clean install.

      TEST-org.geoserver.gwc.GWCCatalogListenerTest.xml: <system-out>29 Jun 09:45:11 ERROR [config.XMLConfiguration] - Configuration file cannot be read or does not exist!
      TEST-org.geoserver.gwc.GWCCatalogListenerTest.xml:29 Jun 09:45:11 ERROR [layer.TileLayerDispatcher] - Configuration /work/geoserver-2.0.x/src/gwc/null/../resources contained no layers.
      TEST-org.geoserver.gwc.GWCCatalogListenerTest.xml:29 Jun 09:45:11 ERROR [layer.TileLayerDispatcher] - Error reading service information from /work/geoserver-2.0.x/src/gwc/null/../resources: Error parsing file /work/geoserver-2.0.x/src/gwc/null/../resources/geowebcache.xml

      1. geoserver-build.log.gz
        61 kB
        Geoff Clitheroe
      2. geoserver-build-14550-clean.log.gz
        61 kB
        Geoff Clitheroe
      3. org.geoserver.gwc.GWCIntegrationTest.txt
        0.3 kB
        Geoff Clitheroe
      4. TEST-org.geoserver.gwc.GWCCatalogListenerTest.xml
        25 kB
        Geoff Clitheroe
      5. TEST-org.geoserver.gwc.GWCIntegrationTest.xml
        24 kB
        Geoff Clitheroe

        Activity

        Arne Kepp added a comment -

        As far as I can tell from the logs you attached, there wasnt a test failure?

        Geoff Clitheroe added a comment -

        Hi,

        the build give a BUILD FAILURE message and refers to the surefire reports. The end of the build is below and I will attach a log file which is the result of

        mvn -e clean install &> ~/geoserver-build.log

        ...

        Results :

        Failed tests:
        testInit(org.geoserver.gwc.GWCCatalogListenerTest)

        Tests run: 2, Failures: 1, Errors: 0, Skipped: 0

        [INFO] ------------------------------------------------------------------------
        [ERROR] BUILD FAILURE
        [INFO] ------------------------------------------------------------------------
        [INFO] There are test failures.

        Please refer to /work/geoserver-2.0.x/src/gwc/target/surefire-reports for the individual test results.
        [INFO] ------------------------------------------------------------------------
        [INFO] For more information, run Maven with the -e switch
        [INFO] ------------------------------------------------------------------------
        [INFO] Total time: 5 minutes 57 seconds
        [INFO] Finished at: Wed Jun 30 13:58:24 NZST 2010
        [INFO] Final Memory: 69M/662M
        [INFO] ------------------------------------------------------------------------

        Cheers,
        Geoff

        Arne Kepp added a comment -

        Checked more, it's just saying it cannot find sf:AggregateGeoFeature in the test data.

        Is this failing consistently for you, or was it a one time event?

        Geoff Clitheroe added a comment -

        The short answer is yes (sorry). I tried running mvn clean install then mvn install a couple of times and I see the same errors.

        This bug was raised against rev14530, I've updated to 14550 and I see the same problem (I think). I can attach a build log for 14550 if that is useful.

        I will now remove my maven cache and try again (takes quite a while).

        geoffc@fin src]$ svn info
        Path: .
        URL: https://svn.codehaus.org/geoserver/branches/2.0.x/src
        Repository Root: https://svn.codehaus.org/geoserver
        Repository UUID: ef1d6e69-97e5-0310-af46-8a06194da32a
        Revision: 14530
        Node Kind: directory
        Schedule: normal
        Last Changed Author: aaime
        Last Changed Rev: 14530
        Last Changed Date: 2010-06-28 01:54:22 +1200 (Mon, 28 Jun 2010)

        Arne Kepp added a comment -

        Have you made any changes in your checkout?

        I can't reproduce this locally and we have a build server than builds continuously.
        http://hudson.opengeo.org/hudson/job/geoserver-2.0.x/

        There have been some intermittent test failures with a known cause, but this is something different afaict.

        Geoff Clitheroe added a comment -

        I have made changes but I ran the tests before I made them and saw the problems. The attached log is from a clean checkout with an empty maven cache.

        svn co https://svn.codehaus.org/geoserver/branches/2.0.x geoserver-2.0.x
        cd geoserver-2.0.x/src/
        mvn -e clean install &> ~/geoserver-build-14550-clean.log

        mvn -v
        Maven version: 2.0.9
        Java version: 1.6.0_17
        OS name: "linux" version: "2.6.32.14-127.fc12.x86_64" arch: "amd64" Family: "unix"

        svn info
        Path: .
        URL: https://svn.codehaus.org/geoserver/branches/2.0.x/src
        Repository Root: https://svn.codehaus.org/geoserver
        Repository UUID: ef1d6e69-97e5-0310-af46-8a06194da32a
        Revision: 14550
        Node Kind: directory
        Schedule: normal
        Last Changed Author: groldan
        Last Changed Rev: 14550
        Last Changed Date: 2010-07-07 05:33:10 +1200 (Wed, 07 Jul 2010)

        Andrea Aime added a comment -

        Mass transition all resolved issue that did not see any further comment in the last month to closed status


          People

          • Assignee:
            Arne Kepp
            Reporter:
            Geoff Clitheroe
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: