Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.0-RC2
    • Component/s: None
    • Labels:
      None
    • Environment:
      nightly build, osx,
    • Number of attachments :
      2

      Description

      have the attached sld that fails to render (in styler) at certain times. individual featuretypestyles render, but in combination and at certain zoom levels, it fails. believe its something with propertylike and null values.

      error:
      30 Sep 13:14:23 ERROR [geoserver.ows] -
      org.vfny.geoserver.wms.WmsException: org.vfny.geoserver.wms.WmsException: Rendering process failed
      at org.vfny.geoserver.wms.responses.GetMapResponse.execute(GetMapResponse.java:442)
      at org.geoserver.ows.adapters.ResponseAdapter.getMimeType(ResponseAdapter.java:48)
      at org.geoserver.ows.Dispatcher.response(Dispatcher.java:692)
      at org.geoserver.ows.Dispatcher.handleRequestInternal(Dispatcher.java:213)
      at org.springframework.web.servlet.mvc.AbstractController.handleRequest(AbstractController.java:153)
      at org.springframework.web.servlet.mvc.SimpleControllerHandlerAdapter.handle(SimpleControllerHandlerAdapter.java:48)
      at org.springframework.web.servlet.DispatcherServlet.doDispatch(DispatcherServlet.java:875)
      at org.springframework.web.servlet.DispatcherServlet.doService(DispatcherServlet.java:809)
      at org.springframework.web.servlet.FrameworkServlet.processRequest(FrameworkServlet.java:571)
      at org.springframework.web.servlet.FrameworkServlet.doGet(FrameworkServlet.java:501)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:707)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:820)
      at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:487)
      at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1093)
      at org.vfny.geoserver.filters.SetCharacterEncodingFilter.doFilter(SetCharacterEncodingFilter.java:108)
      at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1084)
      at org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:265)
      at org.acegisecurity.intercept.web.FilterSecurityInterceptor.invoke(FilterSecurityInterceptor.java:107)
      at org.acegisecurity.intercept.web.FilterSecurityInterceptor.doFilter(FilterSecurityInterceptor.java:72)
      at org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:275)
      at org.acegisecurity.ui.ExceptionTranslationFilter.doFilter(ExceptionTranslationFilter.java:124)
      at org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:275)
      at org.acegisecurity.providers.anonymous.AnonymousProcessingFilter.doFilter(AnonymousProcessingFilter.java:125)
      at org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:275)
      at org.acegisecurity.ui.basicauth.BasicProcessingFilter.doFilter(BasicProcessingFilter.java:174)
      at org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:275)
      at org.acegisecurity.context.HttpSessionContextIntegrationFilter.doFilter(HttpSessionContextIntegrationFilter.java:249)
      at org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:275)
      at org.acegisecurity.util.FilterChainProxy.doFilter(FilterChainProxy.java:149)
      at org.acegisecurity.util.FilterToBeanProxy.doFilter(FilterToBeanProxy.java:98)
      at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1084)
      at org.geoserver.filters.LoggingFilter.doFilter(LoggingFilter.java:73)
      at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1084)
      at org.geoserver.filters.ReverseProxyFilter.doFilter(ReverseProxyFilter.java:183)
      at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1084)
      at org.geoserver.filters.GZIPFilter.doFilter(GZIPFilter.java:41)
      at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1084)
      at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:360)
      at org.mortbay.jetty.security.SecurityHandler.handle(SecurityHandler.java:216)
      at org.mortbay.jetty.servlet.SessionHandler.handle(SessionHandler.java:181)
      at org.mortbay.jetty.handler.ContextHandler.handle(ContextHandler.java:726)
      at org.mortbay.jetty.webapp.WebAppContext.handle(WebAppContext.java:405)
      at org.mortbay.jetty.handler.ContextHandlerCollection.handle(ContextHandlerCollection.java:206)
      at org.mortbay.jetty.handler.HandlerCollection.handle(HandlerCollection.java:114)
      at org.mortbay.jetty.handler.HandlerWrapper.handle(HandlerWrapper.java:152)
      at org.mortbay.jetty.Server.handle(Server.java:324)
      at org.mortbay.jetty.HttpConnection.handleRequest(HttpConnection.java:505)
      at org.mortbay.jetty.HttpConnection$RequestHandler.headerComplete(HttpConnection.java:828)
      at org.mortbay.jetty.HttpParser.parseNext(HttpParser.java:514)
      at org.mortbay.jetty.HttpParser.parseAvailable(HttpParser.java:211)
      at org.mortbay.jetty.HttpConnection.handle(HttpConnection.java:380)
      at org.mortbay.io.nio.SelectChannelEndPoint.run(SelectChannelEndPoint.java:395)
      at org.mortbay.thread.BoundedThreadPool$PoolThread.run(BoundedThreadPool.java:450)
      Caused by: org.vfny.geoserver.wms.WmsException: Rendering process failed
      at org.vfny.geoserver.wms.responses.DefaultRasterMapProducer.produceMap(DefaultRasterMapProducer.java:409)
      at org.vfny.geoserver.wms.responses.GetMapResponse.execute(GetMapResponse.java:421)
      ... 52 more
      Caused by: java.lang.Exception: Error rendering feature
      at org.geotools.renderer.lite.StreamingRenderer.drawOptimized(StreamingRenderer.java:1821)
      at org.geotools.renderer.lite.StreamingRenderer.processStylers(StreamingRenderer.java:1731)
      at org.geotools.renderer.lite.StreamingRenderer.paint(StreamingRenderer.java:676)
      at org.geotools.renderer.shape.ShapefileRenderer.renderWithStreamingRenderer(ShapefileRenderer.java:1510)
      at org.geotools.renderer.shape.ShapefileRenderer.paint(ShapefileRenderer.java:1358)
      at org.geotools.renderer.shape.ShapefileRenderer.paint(ShapefileRenderer.java:270)
      at org.vfny.geoserver.wms.responses.DefaultRasterMapProducer.produceMap(DefaultRasterMapProducer.java:385)
      ... 53 more
      Caused by: java.lang.StringIndexOutOfBoundsException: String index out of range: 8
      at java.lang.String.charAt(String.java:558)
      at java.lang.Character.codePointAt(Character.java:2335)
      at java.util.regex.Pattern$Dot.match(Pattern.java:4100)
      at java.util.regex.Pattern$Curly.match0(Pattern.java:4231)
      at java.util.regex.Pattern$Curly.match0(Pattern.java:4234)
      at java.util.regex.Pattern$Curly.match0(Pattern.java:4234)
      at java.util.regex.Pattern$Curly.match0(Pattern.java:4234)
      at java.util.regex.Pattern$Curly.match(Pattern.java:4205)
      at java.util.regex.Matcher.match(Matcher.java:1114)
      at java.util.regex.Matcher.matches(Matcher.java:495)
      at org.geotools.filter.LikeFilterImpl.evaluate(LikeFilterImpl.java:458)
      at org.geotools.filter.AndImpl.evaluate(AndImpl.java:53)
      at org.geotools.filter.OrImpl.evaluate(OrImpl.java:40)
      at org.geotools.renderer.lite.StreamingRenderer.process(StreamingRenderer.java:1871)
      at org.geotools.renderer.lite.StreamingRenderer.drawOptimized(StreamingRenderer.java:1816)
      ... 59 more

      1. street0924.sld
        43 kB
        alyssa wright
      2. street0930.sld
        43 kB
        alyssa wright

        Issue Links

          Activity

          alyssa wright added a comment -

          updated sld


            People

            • Assignee:
              Justin Deoliveira
              Reporter:
              alyssa wright
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: