GeoServer
  1. GeoServer
  2. GEOS-355

Web-admin can't save WFS datastore

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.3-rc1
    • Fix Version/s: 1.3.2
    • Component/s: Configuration
    • Labels:
      None
    • Environment:
      Geoserver 1.3.RC1, Windows XP
    • Number of attachments :
      0

      Description

      javax.servlet.ServletException: Path specified does not have a valid file.
      C:\Software\Tomcat_5.5\webapps\geoserver\data\featureTypes\WFStest_scs:OMLEIDINGGEODATA

      org.vfny.geoserver.action.SaveXMLAction.saveGeoserver(SaveXMLAction.java:69)
      org.vfny.geoserver.action.SaveXMLAction.execute(SaveXMLAction.java:45)
      org.vfny.geoserver.action.ConfigAction.execute(ConfigAction.java:98)
      org.apache.struts.action.RequestProcessor.processActionPerform(RequestProcessor.java:484)
      org.apache.struts.action.RequestProcessor.process(RequestProcessor.java:274)
      org.apache.struts.action.ActionServlet.process(ActionServlet.java:1482)
      org.apache.struts.action.ActionServlet.doPost(ActionServlet.java:525)
      javax.servlet.http.HttpServlet.service(HttpServlet.java:709)
      javax.servlet.http.HttpServlet.service(HttpServlet.java:802)
      When adding a WFS as datastore with the webadmin tool, the datastore and featuretypes can be configured, but saving the configuration causes this error:

      ************
      root cause

      org.vfny.geoserver.global.ConfigurationException: Path specified does not have a valid file.
      C:\Software\Tomcat_5.5\webapps\geoserver\data\featureTypes\WFStest_scs:OMLEIDINGGEODATA

      org.vfny.geoserver.global.xml.WriterUtils.initFile(XMLConfigWriter.java:961)
      org.vfny.geoserver.global.xml.WriterUtils.initWriteFile(XMLConfigWriter.java:1011)
      org.vfny.geoserver.global.xml.XMLConfigWriter.storeFeatures(XMLConfigWriter.java:619)
      org.vfny.geoserver.global.xml.XMLConfigWriter.store(XMLConfigWriter.java:89)
      org.vfny.geoserver.global.xml.XMLConfigWriter.store(XMLConfigWriter.java:119)
      org.vfny.geoserver.action.SaveXMLAction.saveGeoserver(SaveXMLAction.java:63)
      org.vfny.geoserver.action.SaveXMLAction.execute(SaveXMLAction.java:45)
      org.vfny.geoserver.action.ConfigAction.execute(ConfigAction.java:98)
      org.apache.struts.action.RequestProcessor.processActionPerform(RequestProcessor.java:484)
      org.apache.struts.action.RequestProcessor.process(RequestProcessor.java:274)
      org.apache.struts.action.ActionServlet.process(ActionServlet.java:1482)
      org.apache.struts.action.ActionServlet.doPost(ActionServlet.java:525)
      javax.servlet.http.HttpServlet.service(HttpServlet.java:709)
      javax.servlet.http.HttpServlet.service(HttpServlet.java:802)

      ************

      Probably the filename can't be made, because of the namespace of the featuretype that is added in the filepath (scs.

        Activity

        dblasby added a comment -

        Moved until 1.3.1 – the WFS datastore (and others) need to be tested and either included in the distribution or as a separate .jar plugin.

        Brent Owens added a comment -

        The files and directories are now URL encoded


          People

          • Assignee:
            Brent Owens
            Reporter:
            Thijs Brentjens
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Time Tracking

              Estimated:
              Original Estimate - 1 hour
              1h
              Remaining:
              Remaining Estimate - 1 hour
              1h
              Logged:
              Time Spent - Not Specified
              Not Specified