GeoServer
  1. GeoServer
  2. GEOS-3395

Uploading a style whose name does not match the source filename results in bad configuration

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 2.0-RC1
    • Fix Version/s: 2.0.1
    • Component/s: None
    • Labels:
      None
    • Number of attachments :
      0

      Description

      Via the Wicket UI, start editing a style named 'ramp'. Using the form in the editor page, upload an SLD file named 'test.sld'. Submit, get a success message on the styles list page. styles/ramp.xml will have been created, but there is no styles/ramp.sld to go with it. test.xml and test.sld are now also present, and referencing styles=test in WMS requests works fine.

        Activity

        Andrea Aime added a comment - - edited

        Err... the form in the editor page (as in, the one that does edit an existing style) does not have an upload button? At least on the current trunk, but afaik never did.

        I've tried with creating a new style, called "test", uploading a file called "Lakes.sld", and what I got after saving was Lakes.sld on the file system, and test.xml containing:

        <style>
        <id>StyleInfoImpl-745900d3:12360a841f6:-8000</id>
        <filename>Lakes.sld</filename>
        <name>test</name>
        </style>

        which makes for a usable configuration: I can go back and edit, restart GeoServer, edit the style again, no issues.
        I agree it's odd to use the original file name thought, would be more natural to use <stylename>.sld instead (fixing that is a one liner).

        Soo... so far I cannot reproduce.

        Andrea Aime added a comment -

        David, any feedback on this one? Shall I just close it?
        I cannot reproduce it so...


          People

          • Assignee:
            Andrea Aime
            Reporter:
            David Winslow
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: