GeoServer
  1. GeoServer
  2. GEOS-334

Geoserver does not recognize SVG validated using XMLSpy

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 1.2.3
    • Fix Version/s: 1.3-rc1
    • Component/s: WMS
    • Labels:
      None
    • Environment:
      Apache Tomcat 5.5.4, JDK 1.5.0, JAI 1.1.2, Linux on Opteron processor
    • Number of attachments :
      0

      Description

      An SLD for point features which validates against the OGC schemas using XMLSpy 5.4 will not work with Geoserver. Line and Polygon styles work fine. An extract of the SLD is below. The difficulty appears to be in the case of the element WellKnownName, which in examples on the Geoserver distribution (funkypolyshp.sld) is given as wellknownshape. For OGC compliance the latter is incorrect.

      <?xml version="1.0" encoding="UTF-8"?>
      <!-- edited with XMLSPY v5 rel. 4 U (http://www.xmlspy.com) by A Paul R Cooper (British Antarctic Survey) -->
      <StyledLayerDescriptor xmlns="http://www.opengis.net/sld" xmlns:ogc="http://www.opengis.net/ogc" xmlns:xlink="http://www.w3.org/1999/xlink" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://www.opengis.net/sld
      C:\WEBSER~1\SLDSCH~1\StyledLayerDescriptor.xsd" version="1.0.0">
      <!-- a named layer is the basic building block of an sld document -->
      <NamedLayer>
      <Name>Elevation styles</Name>
      <!-- with in a layer you have Named Styles -->
      <UserStyle>
      <!-- again they have names, titles and abstracts -->
      <Name>elevations</Name>
      <Title>ADD elevation point symbols SLD</Title>
      <Abstract>Provides a symbolization for ADD feature codes</Abstract>
      <!-- FeatureTypeStyles describe how to render different features -->
      <FeatureTypeStyle>
      <FeatureTypeName>feature</FeatureTypeName>
      <Rule>
      <Name>Elevation on Rock (Levelling or Trigonometric)</Name>
      <Title>Elevation on Rock (Levelling or Trigonometric)</Title>
      <ogc:Filter>
      <ogc:PropertyIsEqualTo>
      <ogc:PropertyName>elv00typ</ogc:PropertyName>
      <ogc:Literal>24010</ogc:Literal>
      </ogc:PropertyIsEqualTo>
      </ogc:Filter>
      <PointSymbolizer>
      <Graphic>
      <Mark>
      <WellKnownName>circle</WellKnownName>
      <Fill>
      <CssParameter name="fill">#000000</CssParameter>
      </Fill>
      </Mark>
      <Size>2</Size>
      </Graphic>
      </PointSymbolizer>
      </Rule>
      <Rule>
      <ElseFilter/>
      <PointSymbolizer>
      <Graphic>
      <Mark>
      <WellKnownName>triangle</WellKnownName>
      <Fill>
      <CssParameter name="fill">#ff0000</CssParameter>
      </Fill>
      </Mark>
      </Graphic>
      </PointSymbolizer>
      </Rule>
      </FeatureTypeStyle>
      </UserStyle>
      </NamedLayer>
      </StyledLayerDescriptor>

        Activity

        Alexander Paul Robin Cooper added a comment -

        Apologies - I find that my report was incorrect. There does seem to be an issue with some parts of well-formed SLD PointSymbolizers, but I cannot reproduce the problem.

        dblasby added a comment -

        set a fixed version. I'm unsure if there's a problem here - could we get more details? A simple sld that exhibits the problem would be great.

        Andrea Aime added a comment -

        These issue has been in resolved state for at least one month (quite a bit, a lot more than one month). Batch transitioning them to closed state


          People

          • Assignee:
            Gabriel Roldan
            Reporter:
            Alexander Paul Robin Cooper
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: