GeoServer
  1. GeoServer
  2. GEOS-3209

Report back a proper error exception when GetFeatureInfo QUERY_LAYERS is not a subset of LAYERS

    Details

    • Type: Improvement Improvement
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 1.7.5
    • Fix Version/s: 1.7.7
    • Component/s: None
    • Labels:
      None
    • Number of attachments :
      1

      Description

      Now a NPE is thrown

        Activity

        Andrea Aime added a comment -

        Hi Justin, this is the patch that splits up the heavy parts into separate methods. I've tried to update all of the code to follow suit and also added a missing part in the initFeatureType method, that I guess is used by REST (computing the native by reprojecting back the geographic bound)

        Andrea Aime added a comment -

        Actually a duplicate of GEOS-3412 (or else, we forgot about this one, opened 3412 and associated the commit to that one)


          People

          • Assignee:
            Andrea Aime
            Reporter:
            Andrea Aime
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: