GeoServer
  1. GeoServer
  2. GEOS-3065

Can't create file based CoverageStore with relative URL, FileExistsValidator does not find my URL's

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.0-beta1
    • Component/s: Wicket UI
    • Labels:
      None
    • Number of attachments :
      0

      Description

      Hey Andrea I'm assigning this to you for your revision cause I'm not sure if it's just me doing something wrong.

      The point is I don't seem able to add any file based coverage store using a relative path to the data dir cause I can't find a URL notation that satisfies FileExistsValidator

      Tried the following:

      WicketMessage: Exception 'java.lang.IllegalArgumentException: Value of variable [[path]] could not be resolved while interpolating [[Invalid path: ${path}]]' occurred during validation org.geoserver.web.wicket.FileExistsValidator on component 46:rasterStoreForm:urlPanel:border:paramValue
      
      Root cause:
      
      java.lang.IllegalArgumentException: Value of variable [[path]] could not be resolved while interpolating [[Invalid path: ${path}]]
      at org.apache.wicket.util.string.interpolator.VariableInterpolator.toString(VariableInterpolator.java:136)
      ...
      

        Activity

        Andrea Aime added a comment -

        I think I fixed the issue. Can you verify and close?

        Gabriel Roldan added a comment -

        confirmed. file:coverages/... works.


          People

          • Assignee:
            Andrea Aime
            Reporter:
            Gabriel Roldan
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: