GeoServer
  1. GeoServer
  2. GEOS-300

org.vfny.geoserver.WmsException: WIDTH and HEIGHT incorrectly specified

    Details

    • Type: Wish Wish
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Number of attachments :
      0

      Description

      I found the geoserver and set it up with additional libraries for wms visualization
      I am trying demos,but when I try demos with *.url extension , I am always getting the below exception with this request;

      Can you inform me what is wrong and what I have to do...

      http://localhost:1097/geoserver/wms?bbox=-130,24,-66,50&styles=population&Format=image/png&request=GetMap&layers=states&width=550&height=250&srs=EPSG:4326

      <ServiceException code="">org.vfny.geoserver.WmsException: WIDTH and HEIGHT incorrectly specified at org.vfny.geoserver.requests.readers.wms.GetMapKvpReader.parseMandatoryParameters(GetMapKvpReader.java:277) at org.vfny.geoserver.requests.readers.wms.GetMapKvpReader.getRequest(GetMapKvpReader.java:184) at org.vfny.geoserver.servlets.AbstractService.doGet(AbstractService.java:220) at javax.servlet.http.HttpServlet.service(HttpServlet.java:740) at javax.servlet.http.HttpServlet.service(HttpServlet.java:853) at org.vfny.geoserver.servlets.wms.WmsDispatcher.doResponse(WmsDispatcher.java:137) at org.vfny.geoserver.servlets.wms.WmsDispatcher.doGet(WmsDispatcher.java:106) at javax.servlet.http.HttpServlet.service(HttpServlet.java:740) at javax.servlet.http.HttpServlet.service(HttpServlet.java:853) at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:358) at org.mortbay.jetty.servlet.WebApplicationHandler.dispatch(WebApplicationHandler.java:294) at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:567) at org.mortbay.http.HttpContext.handle(HttpContext.java:1807) at org.mortbay.jetty.servlet.WebApplicationContext.handle(WebApplicationContext.java:525) at org.mortbay.http.HttpContext.handle(HttpContext.java:1757) at org.mortbay.http.HttpServer.service(HttpServer.java:879) at org.mortbay.http.HttpConnection.service(HttpConnection.java:790) at org.mortbay.http.HttpConnection.handleNext(HttpConnection.java:961) at org.mortbay.http.HttpConnection.handle(HttpConnection.java:807) at org.mortbay.http.SocketListener.handleConnection(SocketListener.java:197) at org.mortbay.util.ThreadedServer.handle(ThreadedServer.java:276) at org.mortbay.util.ThreadPool$PoolThread.run(ThreadPool.java:511)</ServiceException>

        Activity

        Artie Konin added a comment -

        Strange indeed Something should go horribly wrong if bundled examples aren't working. From the stack trace I assume that you use "standalone" GeoServer running on Jetty container. I don't have any experience with such configuration, but GeoServer's war file deployed under Tomcat works just as expected. I never ever saw such an error
        Well, I think it will be helpful if you submit some more details on your system's configuration, and, most important, your server's logs. Just set "loggingLevel" to fine in your GeoServer's `services.xml` file, try again that test URL and attach the log to this issue. Maybe this will help to reproduce that strange error.

        BTW, I think that the exception report itself sould be changed in GetMapKvpReader to include "invalid" values of width and height that cause NumberFormatException. Something like this:

        String message = "WIDTH and/or HEIGHT incorrectly specified: width = `" + getValue("WIDTH") + "`, height = `" + getValue("HEIGHT") + "`.";
        throw new WmsException(message);

        I believe this way one would be able to guess the reason of exception without consulting log files


          People

          • Assignee:
            Chris Holmes
            Reporter:
            Ali Kemal
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: