GeoServer
  1. GeoServer
  2. GEOS-2610

A True Type Font Symbol is flipped horizontally when using with a PolygonSymbolizer

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.7.2
    • Fix Version/s: 1.7.3
    • Component/s: Global
    • Labels:
      None
    • Environment:
      Windows XP, Geoserver 1.7.2
    • Number of attachments :
      0

      Description

      Hi

      I emailed the Nabble board today at 4:41pm to show my issue with a true type font symbol. It flips horizontally when called from the SLD.

      I have tested by creating a flipped version of the TFF library and these symbols worked.

      I am unsure if its because i am using the symbol attached to a Polygon Symbolizer or this problem applies to all.

      Your example on the blog using Windings didnt seem to have the issue.

      I have put this as a Major priority but not sure if it warrants that status.

      many thanks

      Tim

        Issue Links

          Activity

          Hide
          Andrea Aime added a comment -

          Should have been fixed. Starting from tomorrow you can grab a nightly build from here:
          http://gridlock.openplans.org/geoserver/1.7.x/

          and check if it works for you as well.

          Show
          Andrea Aime added a comment - Should have been fixed. Starting from tomorrow you can grab a nightly build from here: http://gridlock.openplans.org/geoserver/1.7.x/ and check if it works for you as well.
          Hide
          Andrea Aime added a comment -

          Fixed in gt2

          Show
          Andrea Aime added a comment - Fixed in gt2

            People

            • Assignee:
              Andrea Aime
              Reporter:
              Tim Martin
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: