Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.7.0-RC4
    • Fix Version/s: 1.7.1
    • Component/s: Versioning
    • Labels:
      None
    • Number of attachments :
      0

      Description

      I get a RuntimeException in the response to the following request against geo.openplans.org/sensible:

      <wfs:Transaction xmlns:wfs="http://www.opengis.net/wfs" service="WFSV" version="1.1.0">
        <wfsv:Rollback xmlns:wfsv="http://www.opengis.net/wfsv" typeName="sf:archsites" toFeatureVersion="9"/>
      </wfs:Transaction>
      
      <?xml version="1.0" encoding="UTF-8"?>
      <ows:ExceptionReport version="1.0.0"
        xsi:schemaLocation="http://www.opengis.net/ows http://geo.openplans.org:80/sensible/schemas/ows/1.0.0/owsExceptionReport.xsd"
        xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:ows="http://www.opengis.net/ows">
        <ows:Exception exceptionCode="NoApplicableCode">
          <ows:ExceptionText>java.lang.RuntimeException: Parsing
            failed for Rollback: java.lang.NullPointerException
            Parsing failed for Rollback:
            java.lang.NullPointerException null</ows:ExceptionText>
        </ows:Exception>
      </ows:ExceptionReport>
      

      Not sure whether this is because something is wrong on the backend or my request is invalid, but a more informative error message would help me determine that.

        Activity

        Sebastian Benthall added a comment -

        Verbose exception:

        <?xml version="1.0" encoding="UTF-8"?>
        <ows:ExceptionReport version="1.0.0"
          xsi:schemaLocation="http://www.opengis.net/ows http://geo.openplans.org:80/sensible/schemas/ows/1.0.0/owsExceptionReport.xsd"
          xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:ows="http://www.opengis.net/ows">
          <ows:Exception exceptionCode="NoApplicableCode">
            <ows:ExceptionText>java.lang.RuntimeException: Parsing
              failed for Rollback: java.lang.NullPointerException
              Parsing failed for Rollback:
              java.lang.NullPointerException null</ows:ExceptionText>
            <ows:ExceptionText>Details:</ows:ExceptionText>
        
            <ows:ExceptionText>org.geoserver.platform.ServiceException:
              java.lang.RuntimeException: Parsing failed for
              Rollback: java.lang.NullPointerException  at
              org.geoserver.ows.Dispatcher.exception(Dispatcher.java:1178)
              at
              org.geoserver.ows.Dispatcher.handleRequestInternal(Dispatcher.java:208)
              at
              org.springframework.web.servlet.mvc.AbstractController.handleRequest(AbstractController.java:153)
              at
              org.springframework.web.servlet.mvc.SimpleControllerHandlerAdapter.handle(SimpleControllerHandlerAdapter.java:48)
              at
              org.springframework.web.servlet.DispatcherServlet.doDispatch(DispatcherServlet.java:875)
              at
              org.springframework.web.servlet.DispatcherServlet.doService(DispatcherServlet.java:809)
              at
              org.springframework.web.servlet.FrameworkServlet.processRequest(FrameworkServlet.java:571)
              at
              org.springframework.web.servlet.FrameworkServlet.doPost(FrameworkServlet.java:511)
              at
              javax.servlet.http.HttpServlet.service(HttpServlet.java:710)
              at
              javax.servlet.http.HttpServlet.service(HttpServlet.java:803)
              at
              org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
              at
              org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
              at
              org.vfny.geoserver.filters.SetCharacterEncodingFilter.doFilter(SetCharacterEncodingFilter.java:108)
              at
              org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
              at
              org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
              at
              org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:264)
              at
              org.acegisecurity.intercept.web.FilterSecurityInterceptor.invoke(FilterSecurityInterceptor.java:107)
              at
              org.acegisecurity.intercept.web.FilterSecurityInterceptor.doFilter(FilterSecurityInterceptor.java:72)
              at
              org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:274)
              at
              org.acegisecurity.ui.ExceptionTranslationFilter.doFilter(ExceptionTranslationFilter.java:110)
              at
              org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:274)
              at
              org.acegisecurity.providers.anonymous.AnonymousProcessingFilter.doFilter(AnonymousProcessingFilter.java:125)
              at
              org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:274)
              at
              org.acegisecurity.ui.basicauth.BasicProcessingFilter.doFilter(BasicProcessingFilter.java:178)
              at
              org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:274)
              at
              org.acegisecurity.context.HttpSessionContextIntegrationFilter.doFilter(HttpSessionContextIntegrationFilter.java:229)
              at
              org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:274)
              at
              org.acegisecurity.util.FilterChainProxy.doFilter(FilterChainProxy.java:148)
              at
              org.acegisecurity.util.FilterToBeanProxy.doFilter(FilterToBeanProxy.java:98)
              at
              org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
              at
              org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
              at
              org.geoserver.filters.LoggingFilter.doFilter(LoggingFilter.java:73)
              at
              org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
              at
              org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
              at
              org.geoserver.filters.ReverseProxyFilter.doFilter(ReverseProxyFilter.java:163)
              at
              org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
              at
              org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
              at
              org.geoserver.filters.GZIPFilter.doFilter(GZIPFilter.java:47)
              at
              org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
              at
              org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
              at
              org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:233)
              at
              org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:175)
              at
              org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:128)
              at
              org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
              at
              org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
              at
              org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:263)
              at
              org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:844)
              at
              org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:584)
              at
              org.apache.tomcat.util.net.JIoEndpoint$SocketProcessor.run(JIoEndpoint.java:354)
              at
              java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:885)
              at
              java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:907)
              at java.lang.Thread.run(Thread.java:619) Caused by:
              java.lang.RuntimeException: Parsing failed for
              Rollback: java.lang.NullPointerException  at
              org.geotools.xml.impl.ParseExecutor.visit(ParseExecutor.java:158)
              at
              org.geotools.xml.impl.BindingWalker$BindingExecutionChain.execute(BindingWalker.java:208)
              at
              org.geotools.xml.impl.BindingWalker.walk(BindingWalker.java:174)
              at
              org.geotools.xml.impl.ElementHandlerImpl.endElement(ElementHandlerImpl.java:222)
              at
              org.geotools.xml.impl.ParserHandler.endElement(ParserHandler.java:582)
              at
              org.apache.xerces.parsers.AbstractSAXParser.endElement(Unknown
              Source)  at
              org.apache.xerces.parsers.AbstractXMLDocumentParser.emptyElement(Unknown
              Source)  at
              org.apache.xerces.impl.XMLNSDocumentScannerImpl.scanStartElement(Unknown
              Source)  at
              org.apache.xerces.impl.XMLDocumentFragmentScannerImpl$FragmentContentDispatcher.dispatch(Unknown
              Source)  at
              org.apache.xerces.impl.XMLDocumentFragmentScannerImpl.scanDocument(Unknown
              Source)  at
              org.apache.xerces.parsers.XML11Configuration.parse(Unknown
              Source)  at
              org.apache.xerces.parsers.DTDConfiguration.parse(Unknown
              Source)  at
              org.apache.xerces.parsers.XMLParser.parse(Unknown
              Source)  at
              org.apache.xerces.parsers.AbstractSAXParser.parse(Unknown
              Source)  at
              org.geotools.xml.Parser.parse(Parser.java:180)  at
              org.geoserver.wfsv.xml.v1_1_0.WfsXmlReader.read(WfsXmlReader.java:58)
              at
              org.geoserver.ows.Dispatcher.parseRequestXML(Dispatcher.java:1057)
              at
              org.geoserver.ows.Dispatcher.dispatch(Dispatcher.java:396)
              at
              org.geoserver.ows.Dispatcher.handleRequestInternal(Dispatcher.java:195)
              ... 50 more Caused by: java.lang.NullPointerException
              at
              org.geoserver.wfsv.xml.v1_1_0.RollbackTypeBinding.parse(RollbackTypeBinding.java:104)
              at
              org.geotools.xml.impl.ParseExecutor.visit(ParseExecutor.java:149)
              ... 68 more </ows:ExceptionText>
          </ows:Exception>
        </ows:ExceptionReport>
        
        
        
        Andrea Aime added a comment -

        Fixed on 1.7.x and trunk


          People

          • Assignee:
            Andrea Aime
            Reporter:
            Sebastian Benthall
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: