GeoServer
  1. GeoServer
  2. GEOS-1780

/geoserver not found http 404 error

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Critical Critical
    • Resolution: Cannot Reproduce
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: WMS
    • Labels:
      None
    • Environment:
      HOSTGIS DISTRO
    • Number of attachments :
      0

      Description

      after loading around 20-30 maps

      if you go to the geoserve on the server it gives you this error
      HTTP ERROR: 404

      NOT_FOUND

      RequestURI=/geoserver/

      Powered by jetty://
      GEOSERVER DATA DIR is /usr/geoserver/data_dir
      java.net.BindException: Address already in use
      WARN: Not listening on monitor port: 8079
      3 [main] INFO org.mortbay.log - Logging to org.slf4j.impl.SimpleLogger@a59698 via org.mortbay.log.Slf4jLog
      863 [main] INFO org.mortbay.log - jetty-6.0.1
      2247 [main] INFO org.springframework.web.context.ContextLoader - Root WebApplicationContext: initialization started
      2247 [main] INFO /geoserver - Loading Spring root WebApplicationContext
      2428 [main] INFO org.springframework.beans.factory.xml.XmlBeanDefinitionReader - Loading XML bean definitions from URL [jar:file:/usr/geoserver/webapps/geos$
      2617 [main] INFO org.springframework.beans.factory.xml.XmlBeanDefinitionReader - Loading XML bean definitions from URL [jar:file:/usr/geoserver/webapps/geos$
      2666 [main] INFO org.springframework.beans.factory.xml.XmlBeanDefinitionReader - Loading XML bean definitions from URL [file:/usr/geoserver/webapps/geoserve$
      2721 [main] INFO org.springframework.beans.factory.xml.XmlBeanDefinitionReader - Loading XML bean definitions from URL [jar:file:/usr/geoserver/webapps/geos$
      2863 [main] INFO org.springframework.beans.factory.xml.XmlBeanDefinitionReader - Loading XML bean definitions from URL [jar:file:/usr/geoserver/webapps/geos$
      3230 [main] INFO org.springframework.beans.factory.xml.XmlBeanDefinitionReader - Loading XML bean definitions from URL [jar:file:/usr/geoserver/webapps/geos$
      3297 [main] INFO org.springframework.beans.factory.xml.XmlBeanDefinitionReader - Loading XML bean definitions from URL [jar:file:/usr/geoserver/webapps/geos$
      3407 [main] INFO org.springframework.web.context.support.XmlWebApplicationContext - Bean factory for application context [Root WebApplicationContext]: org.s$
      3435 [main] INFO org.springframework.web.context.support.XmlWebApplicationContext - 72 beans defined in application context [Root WebApplicationContext]
      3491 [main] INFO org.springframework.core.CollectionFactory - Commons Collections 3.x available
      3513 [main] INFO org.springframework.web.context.support.XmlWebApplicationContext - Unable to locate MessageSource with name 'messageSource': using default $
      3529 [main] INFO org.springframework.web.context.support.XmlWebApplicationContext - Unable to locate ApplicationEventMulticaster with name 'applicationEvent$
      3540 [main] INFO org.springframework.ui.context.support.UiApplicationContextUtils - Unable to locate ThemeSource with name 'themeSource': using default [org$
      3549 [main] INFO org.springframework.beans.factory.support.DefaultListableBeanFactory - Pre-instantiating singletons in factory [org.springframework.beans.f$
      ----------------------------------

      • GEOSERVER_DATA_DIR: /usr/geoserver/data_dir
        ----------------------------------
        Feb 29, 2008 10:53:53 AM java.util.prefs.FileSystemPreferences$7 run
        WARNING: Prefs file removed in background /root/.java/.userPrefs/org/vfny/geoserver/global/prefs.xml
        11 [CONFIG] org.vfny.geoserver.global.xml.XMLConfigReader - logging level is CONFIG
        16 [CONFIG] org.vfny.geoserver.global.xml.XMLConfigReader - maxFeatures is 1000000
        17 [CONFIG] org.vfny.geoserver.global.xml.XMLConfigReader - numDecimals returning is 8
        17 [CONFIG] org.vfny.geoserver.global.xml.XMLConfigReader - charSet is UTF-8
        27 [CONFIG] org.vfny.geoserver.global.xml.XMLConfigReader - reading srsXmlStyle: [srsXmlStyle: null]
        3258 [CONFIG] org.vfny.geoserver.global.xml.XMLConfigReader - Loading configuration file: /usr/geoserver/data_dir/catalog.xml
        [Fatal Error] :72:74: The reference to entity "subdivisions" must end with the ';' delimiter.
        7087 [main] INFO org.springframework.beans.factory.support.DefaultListableBeanFactory - Destroying singletons in factory {org.springframework.beans.factory.$
        7088 [main] ERROR org.springframework.web.context.ContextLoader - Context initialization failed
        org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'validation' defined in URL [jar:file:/usr/geoserver/webapps/geoserve$
        org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'config' defined in URL [jar:file:/usr/geoserver/webapps/geoserver/WE$
        java.lang.RuntimeException: Error reading : java.io.InputStreamReader@95da38
        at org.geoserver.util.ReaderUtils.parse(ReaderUtils.java:72)
        at org.vfny.geoserver.global.xml.XMLConfigReader.loadCatalog(XMLConfigReader.java:323)
        at org.vfny.geoserver.global.xml.XMLConfigReader.load(XMLConfigReader.java:197)
        at org.vfny.geoserver.global.xml.XMLConfigReader.<init>(XMLConfigReader.java:155)
        at org.vfny.geoserver.global.Config.setApplicationContext(Config.java:69)
        at org.springframework.context.support.ApplicationContextAwareProcessor.postProcessBeforeInitialization(ApplicationContextAwareProcessor.java:84)
        at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.applyBeanPostProcessorsBeforeInitialization(AbstractAutowireCapableB$
        at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.createBean(AbstractAutowireCapableBeanFactory.java:362)
        at org.springframework.beans.factory.support.AbstractBeanFactory.getBean(AbstractBeanFactory.java:226)
        at org.springframework.beans.factory.support.AbstractBeanFactory.getBean(AbstractBeanFactory.java:147)
        at org.springframework.beans.factory.support.BeanDefinitionValueResolver.resolveReference(BeanDefinitionValueResolver.java:176)
        at org.springframework.beans.factory.support.BeanDefinitionValueResolver.resolveValueIfNecessary(BeanDefinitionValueResolver.java:105)
        at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.resolveConstructorArguments(AbstractAutowireCapableBeanFactory.java:$
        at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.autowireConstructor(AbstractAutowireCapableBeanFactory.java:611)
        at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.createBean(AbstractAutowireCapableBeanFactory.java:329)
        at org.springframework.beans.factory.support.AbstractBeanFactory.getBean(AbstractBeanFactory.java:226)
        at org.springframework.beans.factory.support.AbstractBeanFactory.getBean(AbstractBeanFactory.java:147)
        at org.springframework.beans.factory.support.DefaultListableBeanFactory.preInstantiateSingletons(DefaultListableBeanFactory.java:275)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
        at java.lang.reflect.Method.invoke(Unknown Source)
        at org.mortbay.start.Main.invokeMain(Main.java:183)
        at org.mortbay.start.Main.start(Main.java:497)
        at org.mortbay.start.Main.main(Main.java:115)
        Caused by: org.xml.sax.SAXParseException: The reference to entity "subdivisions" must end with the ';' delimiter.
        at org.apache.xerces.parsers.DOMParser.parse(Unknown Source)
        at org.apache.xerces.jaxp.DocumentBuilderImpl.parse(Unknown Source)
        at org.geoserver.util.ReaderUtils.parse(ReaderUtils.java:69)
        ... 43 more
        7095 [main] WARN org.mortbay.log - failed ContextHandler@180cf2a {/geoserver,file:/usr/geoserver/webapps/geoserver/}

        7095 [main] WARN org.mortbay.log - failed ContextHandlerCollection@1a0d866
        7111 [main] WARN org.mortbay.log - failed HandlerCollection@4cd580
        7130 [main] WARN org.mortbay.log - failed SelectChannelConnector @ 0.0.0.0:8080
        7130 [main] WARN org.mortbay.log - failed Server@1cbda0a
        7130 [main] WARN org.mortbay.log - EXCEPTION
        org.mortbay.util.MultiException[org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'validation' defined in URL [jar:file$
        at org.mortbay.jetty.Server.doStart(Server.java:192)
        at org.mortbay.component.AbstractLifeCycle.start(AbstractLifeCycle.java:38)
        at org.mortbay.xml.XmlConfiguration.main(XmlConfiguration.java:905)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
        at java.lang.reflect.Method.invoke(Unknown Source)
        at org.mortbay.start.Main.invokeMain(Main.java:183)
        at org.mortbay.start.Main.start(Main.java:497)
        at org.mortbay.start.Main.main(Main.java:115)
        org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'validation' defined in URL [jar:file:/usr/geoserver/webapps/geoserve$
        org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'config' defined in URL [jar:file:/usr/geoserver/webapps/geoserver/WE$
        java.lang.RuntimeException: Error reading : java.io.InputStreamReader@95da38

        Activity

        Andrea Aime added a comment -

        Hum, it seems that your catalog.xml file got corrupted, not sure why... can you attach it here?


          People

          • Assignee:
            Andrea Aime
            Reporter:
            Drew Trainum
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: