GeoServer
  1. GeoServer
  2. GEOS-1695

WCS 1.0 GetCoverage does not properly sets the content type

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 1.6.0-RC3
    • Fix Version/s: 1.7.0-beta2
    • Component/s: WCS
    • Labels:
      None
    • Number of attachments :
      0

      Description

      The output of the sample GetCoverage request is completely garbled... if you choose GEOTIFF as the format, the content type is "application/octect-stream". If you choose PNG or TIFF the output is some black thing that, when saved, no program can open...

        Activity

        Andrea Aime added a comment -

        The output is not garbled, not exactly.
        First, no content type is ever set due to a piece of code commented out
        Second, the sample request does a band select, and the result for png is an 8bit png with no palette, that various apps cannot open, but I'm not sure whether to consider this an error, I mean, the request does not fully make sense either...

        Andrea Aime added a comment -

        Hum, no, this already has been fixed by jdeolive a few days ago... but trunk still has this

        Justin Deoliveira added a comment -
        David Winslow added a comment -

        Couldn't reproduce (and there's a comment saying it's fixed) so I'm closing this one.


          People

          • Assignee:
            David Winslow
            Reporter:
            Andrea Aime
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: