GeoServer
  1. GeoServer
  2. GEOS-1694

Bridge to old style service API disregards content disposition

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.6.0-RC3
    • Fix Version/s: 1.7.0-RC1
    • Component/s: None
    • Labels:
      None
    • Number of attachments :
      0

      Description

      The old AbstractServices had a getContentDisposition method to allow a file to be returned as "save as" type (attachement content disposition) instead of directly opening in the brower.
      The bridge between the old and new api disregards it, making everything open straight into the browser.
      It is a sort of a regression, thought not that bad... maybe it's something we can delay to 1.6.1

        Activity

        Andrea Aime added a comment -

        All these issues have been in "resolved" state for at least one month (many of them, much more than that). Since no one has reopened them, I'm mass-switching them to closed state. Reopen if you feel the issue has not been addressed properly.


          People

          • Assignee:
            Justin Deoliveira
            Reporter:
            Andrea Aime
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: