GeoServer
  1. GeoServer
  2. GEOS-168

Saving with Web Admin tool clobbers style information.

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.2.0-rc1
    • Fix Version/s: 1.2.0-rc2
    • Component/s: None
    • Labels:
      None
    • Number of attachments :
      0

      Description

      This was first reported by James, but I've since reproduced the problem. I'm not sure where this happens, if it's in XMLConfig or in some definitions elsewhere, my initial investigation seems to be that XMLConfig is being passed screwy values. Basically what happens is one file for a style will become the definition for most all the style elements. So in my case the gray.sld file becomes the file for the red, blue, ect. styles. One interesting thing to note is that the normal sld file remained untouched, perhaps because it wasn't called? Maybe some code when calling styles somehow changes them. Needs more digging.

        Activity

        Chris Holmes added a comment -

        Ok, I think I fixed this, though it'd be nice to get some feedback from you James. Give a comment and/or reopen if you still have the problem (though I imagine you're pretty busy these days). But I think what was causing the clobbering was the fact that we often put the 'name' field of the sld file as the same. (like when you just change one little thing and save it as a different file). GeoServer was using that name to reference and then store files, so I think that's what messed things up. So I'm gonna close, re-open if that wasn't your problem.


          People

          • Assignee:
            James Macgill
            Reporter:
            Chris Holmes
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: