Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 1.6.0-RC1
    • Fix Version/s: 1.6.0-RC2
    • Component/s: Versioning
    • Labels:
      None
    • Testcase included:
      yes
    • Number of attachments :
      0

      Description

      (Scheduling against 1.6.1 so it won't show up on the RC2 list): Sebastian go the following traceback when trying a request that has worked previously:

      <wfs:GetFeature xmlns:wfs="http://www.opengis.net/wfs" version="1.0.0" service="WFS" outputFormat="GML2" xmlns:topp="http://www.openplans.org/topp" xmlns:ogc="http://www.opengis.net/ogc" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://www.opengis.net/wfs http://schemas.opengis.net/wfs/1.0.0/WFS-basic.xsd"><wfs:Query typeName="topp:notes" srsName="EPSG:900913"/></wfs:GetFeature>

      -----------------------------

      <ServiceExceptionReport version="1.2.0" xsi:schemaLocation="http://www.opengis.net/ogc http://schemas.opengis.net/wfs/1.0.0/OGC-exception.xsd">
      <ServiceException>
      java.lang.RuntimeException: No response: ( object = class net.opengis.wfs.impl.FeatureCollectionTypeImpl, outputFormat = GML2 )
      java.lang.RuntimeException: No response: ( object = class net.opengis.wfs.impl.FeatureCollectionTypeImpl, outputFormat = GML2 )
      Details:
      org.geoserver.platform.ServiceException: java.lang.RuntimeException: No response: ( object = class net.opengis.wfs.impl.FeatureCollectionTypeImpl, outputFormat = GML2 )
      at org.geoserver.ows.Dispatcher.exception(Dispatcher.java:1153)
      at org.geoserver.ows.Dispatcher.handleRequestInternal(Dispatcher.java:198)
      at org.springframework.web.servlet.mvc.AbstractController.handleRequest(AbstractController.java:139)
      at org.springframework.web.servlet.mvc.SimpleControllerHandlerAdapter.handle(SimpleControllerHandlerAdapter.java:44)
      at org.springframework.web.servlet.DispatcherServlet.doDispatch(DispatcherServlet.java:684)
      at org.springframework.web.servlet.DispatcherServlet.doService(DispatcherServlet.java:625)
      at org.springframework.web.servlet.FrameworkServlet.processRequest(FrameworkServlet.java:392)
      at org.springframework.web.servlet.FrameworkServlet.doPost(FrameworkServlet.java:357)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:710)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:803)
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
      at org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:264)
      at org.acegisecurity.intercept.web.FilterSecurityInterceptor.invoke(FilterSecurityInterceptor.java:107)
      at org.acegisecurity.intercept.web.FilterSecurityInterceptor.doFilter(FilterSecurityInterceptor.java:72)
      at org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:274)
      at org.acegisecurity.ui.ExceptionTranslationFilter.doFilter(ExceptionTranslationFilter.java:110)
      at org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:274)
      at org.acegisecurity.providers.anonymous.AnonymousProcessingFilter.doFilter(AnonymousProcessingFilter.java:125)
      at org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:274)
      at org.acegisecurity.ui.basicauth.BasicProcessingFilter.doFilter(BasicProcessingFilter.java:178)
      at org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:274)
      at org.acegisecurity.context.HttpSessionContextIntegrationFilter.doFilter(HttpSessionContextIntegrationFilter.java:229)
      at org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:274)
      at org.acegisecurity.util.FilterChainProxy.doFilter(FilterChainProxy.java:148)
      at org.acegisecurity.util.FilterToBeanProxy.doFilter(FilterToBeanProxy.java:98)
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
      at org.vfny.geoserver.filters.SetCharacterEncodingFilter.doFilter(SetCharacterEncodingFilter.java:108)
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
      at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:233)
      at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:175)
      at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:128)
      at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
      at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
      at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:263)
      at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:844)
      at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:584)
      at org.apache.tomcat.u
      til.net.JIoEndpoint$Worker.run(JIoEndpoint.java:447)
      at java.lang.Thread.run(Thread.java:619)
      Caused by: java.lang.RuntimeException: No response: ( object = class net.opengis.wfs.impl.FeatureCollectionTypeImpl, outputFormat = GML2 )
      at org.geoserver.ows.Dispatcher.response(Dispatcher.java:555)
      at org.geoserver.ows.Dispatcher.handleRequestInternal(Dispatcher.java:192)
      ... 39 more

      </ServiceException>
      </ServiceExceptionReport>

        Activity

        Andrea Aime added a comment -

        This does not make sense to me... it's a plain jane WFS 1.0 request, has nothing to do with versioning, and besides wfs unit tests for it are passing... I don't understand how this can be happening?
        Justin, any idea about what might be going wrong?

        Andrea Aime added a comment -

        Ah, found the reason. In the wfsv applicationContext.xml I registered the versioned gml2 output format with the same name as the wfs one... glab.
        The unit tests in wfs won't pick any issue because the wfsv jar is not around during unit testing.
        Wondering if there is any way to avoid this, that is, have application context complain loudly if two beans are found with the same name.... this would
        break the current (fragile) integration with the TOPP portal (since it relies on this kind of override), but this is something we have to improve on anyways
        (make the main dao be a router and have the actual user dao selectable thru a setting, such as in web.xml)

        Andrea Aime added a comment -

        Fixed on 1.6.x, will port to trunk as I move the other wfsv changes

        Andrea Aime added a comment -

        Fixed on trunk too


          People

          • Assignee:
            Andrea Aime
            Reporter:
            Arne Kepp
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: