GeoServer
  1. GeoServer
  2. GEOS-1563

unclear problem in getcapabilities response

    Details

    • Type: Improvement Improvement
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.6.0-RC1
    • Fix Version/s: 1.6.0-RC2
    • Component/s: None
    • Labels:
      None
    • Number of attachments :
      0

      Description

      when there are some trouble with a datastor eor layer the following respons will show up efter a getcapabilities request.
      It should be nice to have information of which datastore or/and layer instead of translator error.

      <?xml version="1.0" encoding="UTF-8" standalone="no"?><!DOCTYPE ServiceExceptionReport SYSTEM "http://schemas.opengis.net/wms/1.1.1/WMS_exception_1_1_1.dtd"> <ServiceExceptionReport version="1.1.1" > <ServiceException>
      Translator error
      Translator error
      Translator error
      Translator error
      </ServiceException></ServiceExceptionReport>

        Activity

        Andrea Aime added a comment -

        Which version of GeoServer are you using?

        Mikael Hamström added a comment -

        THANKS ! Ok, I found the problem ! It was the layer groups.

        But the configurations look ok, but when I removed my layer groups (3 groups, with 3 'sub-layers' each , with bounds generated be geoserver) so I really don't know reason of the trouble.

        Mikael Hamström added a comment -

        I 'm using 1.6.0 RC1

        Andrea Aime added a comment -

        The reason is that there is some misconfiguration in those layers, probably in the declared srs, and GeoServer got to work with impossible coordinates (see the error "Latitude 77681°46.0'N is out of range (±90°).").
        If you can give me those layers and the srs you configured for them I can try to reproduce the issue on my pc.

        Andrea Aime added a comment -

        Improved error messages, now they should cite the name of the layer having transformation issues. There is not much else I can do.


          People

          • Assignee:
            Andrea Aime
            Reporter:
            Mikael Hamström
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: