GeoServer
  1. GeoServer
  2. GEOS-1457

Distortion in rendering svg file

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Won't Fix
    • Affects Version/s: 1.6.0-beta4
    • Fix Version/s: None
    • Component/s: WMS
    • Labels:
      None
    • Number of attachments :
      0

      Description

      The attached sld+svg file is not rendered properly. The external circle looks more like an egg than a circle.
      Tests with Squiggle seem to suggest the problem is with batik, so a batik bug has been opened to
      handle this:
      http://issues.apache.org/bugzilla/show_bug.cgi?id=43744

        Activity

        Andrea Aime added a comment -

        Batik people told me that the svg document should be fixed by adding the {{shape-
        rendering="geometricPrecision"}} attribute to it.


          People

          • Assignee:
            Andrea Aime
            Reporter:
            Andrea Aime
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: