GeoServer
  1. GeoServer
  2. GEOS-1435

WFS GET bbox parsing looses axis orientation

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.6.0-beta3
    • Fix Version/s: 1.6.0-RC1
    • Component/s: WFS
    • Labels:
      None
    • Number of attachments :
      0

      Description

      Given the following request (coming from cite wfs 1.1):
      http://localhost:8080/geoserver/wfs?&service=WFS&version=1.1.0&request=GetFeature&typename=sf:PrimitiveGeoFeature&bbox=34.94,-10.52,71.96,32.19,urn:x-ogc:def:crs:EPSG:6.11.2:4326&namespace=xmlns(sf=http://cite.opengeospatial.org/gmlsf)http://

      the bbox parser will generate a correct referenced envelope, which will be wrongly turned into a bbox filter thought...
      The problem is that only the code is extracted from the CRS, and then the srs code for bboxfilter is rebuilt as
      EPSG:XXXX

      So the above bbox srs goes from urn:x-ogc:def:crs:EPSG:6.11.2:4326 to EPSG:4326 in the filter loosing axis orientation.
      I'd say, either some workaround is found to set the code with the proper axis orientation in the bbox filter, or the parsing code should be changed so that bbox directly parses into a bboxfilter (thus avoiding all of these girations).

      Opinions?

        Issue Links

          Activity

          Justin Deoliveira added a comment -

          cool, lets see if the determining axis flipping from the crs object itself will work and apply it here as well.

          Andrea Aime added a comment -

          Reassigning axis order issues to me

          Andrea Aime added a comment -

          Fixed on trunk


            People

            • Assignee:
              Andrea Aime
              Reporter:
              Andrea Aime
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: