GeoServer
  1. GeoServer
  2. GEOS-1362

Data from postgis not rendered correctly

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.6.0-beta3
    • Fix Version/s: 1.6.0-beta4
    • Component/s: WMS
    • Labels:
      None
    • Environment:
      ( Tomcat 5.5, Java 5, 64 bit ) AND (Jetty / SVN Trunk, Java 6 , x86)
    • Number of attachments :
      3

      Description

      SLD styles are not applied correctly when the data comes from Postgis.

      For instance, I may want to create an outline effect by drawing street centerlines in as an 8px wide grey line on top of a 10 px wide green line. With data from Postgis, only the style listed first in the SLD file is applied. See the attached SLD.

      I have tested this using railroads in NYC, retrieving the same data in a shapefile and in Postgis. I have also tested using the tiger_road style (without modification, the railroads also have a NAME string) with identical results.
      .
      I believe that text labels have the same problem.

      1. line2.sld
        1 kB
        Arne Kepp
      1. expected.png
        12 kB
      2. observed.png
        12 kB

        Issue Links

          Activity

          Hide
          Andrea Aime added a comment -

          This has been fixed in geotools with GEOT-1500

          Show
          Andrea Aime added a comment - This has been fixed in geotools with GEOT-1500

            People

            • Assignee:
              Andrea Aime
              Reporter:
              Arne Kepp
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: