FEST
  1. FEST
  2. FEST-246

JTreeDriver: drop() fails when root tree not visible

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: FEST-Swing 1.2a3
    • Fix Version/s: FEST-Swing 1.2a4
    • Component/s: Swing
    • Labels:
      None
    • Environment:
      Windows, JRE 1.5
    • Number of attachments :
      0

      Description

      When testing Drag & Drop operations on a tree with setRootVisible(false), the Method JTreeDriver.drop(JTree, String) fails.

      Specifically, scrollToMatchingPath(JTree, String, JTreePathFinder, JTreeLocation) uses findMatchingPath without addRootIfInvisble. getPathBounds then seems to return null, leading to a NullPointerException in scrollRectToVisible.

      I hope I am not wrong

        Activity

        Alex Ruiz made changes -
        Field Original Value New Value
        Assignee Alex Ruiz [ alexruiz ]
        Alex Ruiz made changes -
        Fix Version/s FEST-Swing 1.2a4 [ 15506 ]
        Alex Ruiz made changes -
        Original Estimate 0 minutes [ 0 ]
        Remaining Estimate 0 minutes [ 0 ]
        Alex Ruiz made changes -
        Status Open [ 1 ] In Progress [ 3 ]
        Alex Ruiz added a comment -

        Hi Pavol,

        I couldn't reproduce the bug with the latest version (1.2a4 SNAPSHOT.) It may have been fixed already (a side effect of fixing another bug.)

        Alex Ruiz made changes -
        Resolution Cannot Reproduce [ 5 ]
        Status In Progress [ 3 ] Resolved [ 5 ]
        Alex Ruiz added a comment -

        Please take a look at the method should_drag_and_drop_when_root_is_invisible in JTreeDriver_dragPath_dropPath_Test

        Alex Ruiz added a comment -

        My bad, the test verifies drag but not drop. I'm reopening the bug.

        Alex Ruiz made changes -
        Resolution Cannot Reproduce [ 5 ]
        Status Resolved [ 5 ] Reopened [ 4 ]
        Alex Ruiz added a comment -

        Now it's fixed for real

        Alex Ruiz made changes -
        Resolution Fixed [ 1 ]
        Status Reopened [ 4 ] Resolved [ 5 ]

          People

          • Assignee:
            Alex Ruiz
            Reporter:
            Pavol Marko
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: