I've noticed that we're using different parameter variable names in the assert class methods, sometimes we us "expected", other times "other" and occasionally "obj".
How important is it to be consistent here? For asserts that are testing for equality or something similar, "expected" makes sense, but for isNotEqualTo() (for example), "other" is used. Not sure about "obj" (probably should be "other"). For numeric asserts, "value" is used instead of "other". Seems to me we could just use "other".