FEST
  1. FEST
  2. FEST-136

Modifiers behaviour incorrect for JTableFixture

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: FEST-Swing 1.1
    • Fix Version/s: FEST-Swing 1.2a3
    • Component/s: Swing
    • Labels:
      None
    • Environment:
      Windows XP, Java 6, Eclipse, JUnit 4.4, fest-swing 1.1
    • Testcase included:
      yes
    • Number of attachments :
      2

      Description

      Using the CONTROL modifier then clicking a table cell selects the range of rows not individual rows (same behaviour as manual use of the SHIFT modifier). Using the SHIFT modifier does nothing, only the row clicked on is selected.

      A test case has been attached.

      The work around is to ask the table fixture to select the rows rather than simulating user interaction via keyboard and mouse.

        Activity

        Alex Ruiz added a comment -

        Thanks Steve!

        Alex Ruiz added a comment -

        This is not a bug. The problem was that the given test case uses values from java.awt.event.KeyEvent for the masks. The values for the SHIFT and CTRL masks should come from java.awt.event.InputEvent instead.

        I'm updating Robot's Javadocs to avoid this confusion in the future.


          People

          • Assignee:
            Alex Ruiz
            Reporter:
            Steve
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: