EasyMock
  1. EasyMock
  2. EASYMOCK-43

Update maven-javadoc-plugin to 2.7 (Maven build broken)

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.0
    • Fix Version/s: 3.1
    • Component/s: Core
    • Labels:
      None

      Description

      The existing version (2.6.1) of maven-javadoc-plugin used in the build can cause a top-level build to fail on Maven 2.2.1:

      [INFO] Unable to find resource 'org.easymock:easymock:jar:3.1-SNAPSHOT' in repository snapshots (http://snapshots)
      [INFO] ------------------------------------------------------------------------
      [ERROR] BUILD ERROR
      [INFO] ------------------------------------------------------------------------
      [INFO] Failed to resolve artifact.

      Missing:
      ----------
      1) org.easymock:easymock:jar:3.1-SNAPSHOT

      I believe that this is a known problem with this plugin, which can be fixed by moving up to version 2.7.

      POM patch attached.

        Activity

        Henri Tremblay made changes -
        Field Original Value New Value
        Status Open [ 1 ] In Progress [ 3 ]
        Hide
        Henri Tremblay added a comment -

        All plugins updated to latest version

        Show
        Henri Tremblay added a comment - All plugins updated to latest version
        Henri Tremblay made changes -
        Status In Progress [ 3 ] Resolved [ 5 ]
        Fix Version/s 3.1 [ 17672 ]
        Resolution Fixed [ 1 ]
        Henri Tremblay made changes -
        Status Resolved [ 5 ] Closed [ 6 ]

          People

          • Assignee:
            Henri Tremblay
            Reporter:
            Henri Tremblay
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: