Maven Doxia Sitetools
  1. Maven Doxia Sitetools
  2. DOXIASITETOOLS-70

Html title of generated pages does not include project name

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.2
    • Fix Version/s: 1.3
    • Component/s: Site renderer
    • Labels:
      None
    • Environment:
    • Number of attachments :
      2

      Description

      Dear maintainer,

      according to http://maven.apache.org/plugins/maven-site-plugin/examples/sitedescriptor.html the title of each page should be the concatenation of the site title and the title of the current page. E.g. if in pom.xml the name element is:
      <name>Site Plugin Test</name>
      then target/site/index.html should have a line
      <title>Site Plugin Test - About<title>

      This is not working. The site title is missing and the created index.html only contains
      <title>About</title>

      This effects how the page is shown in Google, Bing and other search engines. To have the page correctly related in search machines with the project it is desirable to have the project name in the HTML title.

      For testing you can use the appended pom.xml

      Best regards

      Heinrich Schuchardt

      1. pom.xml
        1 kB
        Heinrich Schuchardt
      2. pom.xml
        1 kB
        Heinrich Schuchardt

        Issue Links

          Activity

          Dennis Lundberg added a comment -

          The reason for the change in behavior compared to previous versions can most likely be found in this commit:
          https://svn.apache.org/viewvc?view=revision&revision=1054241

          Dennis Lundberg added a comment -

          The problem was that the $title property was used for 2 different things in the velocity template: the title and the name of the last breadcrumb. They want different titles. The page title should include the project name, but the breadcrumb should not. I solved this by a adding a new property called $shortTitle that is now used by the breadcrumb generation.

          Fixed in r1309906.

          Change your pom.xml to this:

                      <plugin>
                          <groupId>org.apache.maven.plugins</groupId>
                          <artifactId>maven-site-plugin</artifactId>
                          <version>3.0</version>
                          <dependencies>
                            <dependency>
                              <groupId>org.apache.maven.doxia</groupId>
                              <artifactId>doxia-site-renderer</artifactId>
                              <version>1.3-SNAPSHOT</version>
                            </dependency>
                          </dependencies>
                      </plugin>
          
          Heinrich Schuchardt added a comment -

          I added the dependency as proposed. The bug still occurs.

          Heinrich Schuchardt added a comment -

          Pom with dependency added.

          Heinrich Schuchardt added a comment -

          Might it be that the snapshot has not been published?

          _maven.repositories contains the following:
          #NOTE: This is an internal implementation file, its format can be changed without prior notice.
          #Fri Apr 06 07:40:28 CEST 2012
          doxia-site-renderer-1.3-20120225.144406-1.pom>apache.snapshots=
          doxia-site-renderer-1.3-20120225.144406-1.jar>apache.snapshots=

          Dennis Lundberg added a comment -

          Heinrich,

          Yes, it seems that our CI is not setup to deploy the built artifacts. I'm working on fixing that now.

          Dennis Lundberg added a comment -

          The artifacts are available in our SNAPSHOT repository now.

          Dennis Lundberg added a comment -

          Heinrich,

          Have you had time to confirm that it is working for you now?

          Heinrich Schuchardt added a comment -

          Dear Dennis,

          with the artifacts available from http://repository.apache.org/snapshots/ the problem is resolved.

          Thank you for your support.

          Best regards

          Heinrich


            People

            • Assignee:
              Dennis Lundberg
              Reporter:
              Heinrich Schuchardt
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: