Maven Doxia Sitetools
  1. Maven Doxia Sitetools
  2. DOXIASITETOOLS-60

Useless error message "error in opening zip file" in DefaultSiteRenderer.createContextForSkin()

    Details

    • Type: Improvement Improvement
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.2
    • Fix Version/s: 1.3
    • Component/s: Site renderer
    • Labels:
      None
    • Number of attachments :
      0

      Description

      When I run mvn site on my project, I get an exception in DefaultSiteRenderer.createContextForSkin(): "error in opening zip file"

      Which zip file?

        Activity

        Aaron Digulla added a comment -

        Here is the full stack trace:

        [ERROR] Failed to execute goal org.apache.maven.plugins:maven-site-plugin:3.0-beta-3:site (default-site) on project ExBib: Error during site generation: error in opening zip file -> [Help 1]
        org.apache.maven.lifecycle.LifecycleExecutionException: Failed to execute goal org.apache.maven.plugins:maven-site-plugin:3.0-beta-3:site (default-site) on project ExBib: Error during site generation
        	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:217)
        	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:153)
        	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:145)
        	at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:84)
        	at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:59)
        	at org.apache.maven.lifecycle.internal.LifecycleStarter.singleThreadedBuild(LifecycleStarter.java:183)
        	at org.apache.maven.lifecycle.internal.LifecycleStarter.execute(LifecycleStarter.java:161)
        	at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:319)
        	at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:156)
        	at org.apache.maven.cli.MavenCli.execute(MavenCli.java:534)
        	at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:196)
        	at org.apache.maven.cli.MavenCli.main(MavenCli.java:141)
        	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        	at java.lang.reflect.Method.invoke(Method.java:597)
        	at org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launcher.java:290)
        	at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:230)
        	at org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:409)
        	at org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:352)
        Caused by: org.apache.maven.plugin.MojoExecutionException: Error during site generation
        	at org.apache.maven.plugins.site.SiteMojo.execute(SiteMojo.java:131)
        	at org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(DefaultBuildPluginManager.java:107)
        	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:209)
        	... 19 more
        Caused by: java.util.zip.ZipException: error in opening zip file
        	at java.util.zip.ZipFile.open(Native Method)
        	at java.util.zip.ZipFile.<init>(ZipFile.java:127)
        	at java.util.zip.ZipFile.<init>(ZipFile.java:144)
        	at org.apache.maven.doxia.siterenderer.DefaultSiteRenderer.createContextForSkin(DefaultSiteRenderer.java:616)
        	at org.apache.maven.plugins.site.AbstractSiteRenderingMojo.createSiteRenderingContext(AbstractSiteRenderingMojo.java:312)
        	at org.apache.maven.plugins.site.SiteMojo.renderLocale(SiteMojo.java:138)
        	at org.apache.maven.plugins.site.SiteMojo.execute(SiteMojo.java:122)
        	... 21 more
        
        Aaron Digulla added a comment -

        Please add a try/catch in createContextForSkin() that adds the file name to the error message (with absolute path).

        Lukas Theussl added a comment -

        What skin are you using (mvn site:effective-site)? Can you check if that skin jar is not corrupt?

        Lukas Theussl added a comment -

        Improved error message: r1126622

        Aaron Digulla added a comment -

        The JAR file seems OK so the problem must be that Maven is pulling something in that I don't expect/see.

        How can I get this version of Doxia to test?

        Lukas Theussl added a comment -

        Try site-plugin-2.4-SNAPSHOT. Also did you run with -X to get the full debug output?

        Aaron Digulla added a comment -

        Yes. The debug output doesn't list the resources which the plugin loads. That might be a valuable addition.


          People

          • Assignee:
            Lukas Theussl
            Reporter:
            Aaron Digulla
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: