Maven Doxia
  1. Maven Doxia
  2. DOXIA-93

xdoc renderer chokes on multiple block elements in a section

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.0-alpha-8
    • Fix Version/s: 1.0-alpha-9
    • Component/s: Core
    • Labels:
      None
    • Number of attachments :
      2

      Description

      Consider the following xdoc file:

      <?xml version="1.0" encoding="UTF-8"?>
      <document>
      <properties>
      <title>test1</title>
      </properties>

      <body>
      <section name="section name">
      <p>text</p>
      <ul>
      <li>list1</li>
      </ul>
      <p>text2</p>
      <ul>
      <li>list1</li>
      </ul>
      <p>text3</p>
      </section>
      </body>
      </document>

      The current doxia HEAD renders this to:

      <a name="section name"></a><div class="section"><h2>section name</h2>
      <p>text</p>
      <ul>
      <li>list1</li>
      </ul>
      text2
      <ul>
      <li>list1</li>
      </ul>
      text3
      </div>

      Note the missing '<p>' tags around text2 and text3.

      1. pom_1
        0.7 kB
        Henning Schmiedehausen
      2. pom_2
        1.0 kB
        Henning Schmiedehausen

        Activity

        Dennis Lundberg added a comment -

        There has been an ongoing discussion about this on the Maven users list. See
        http://mail-archives.apache.org/mod_mbox/maven-users/200701.mbox/%3c8236846.post@talk.nabble.com%3e
        and
        http://mail-archives.apache.org/mod_mbox/maven-users/200701.mbox/%3c8268299.post@talk.nabble.com%3e

        In short - I have not been able to reproduce this using doxia HEAD, or any other version for that matter.

        Henning Schmiedehausen added a comment -

        That is because, an empty POM DOES work. Which is scary. Really scary. The following result was rendered using attached POM 1:

        <a name="section_1"></a><div class="section"><h2>section 1</h2>
        <p>text 1</p>
        <ul>
        <li>list1</li>
        </ul>
        <p>text 2</p>
        <ul>
        <li>list1</li>
        </ul>
        <p>text 3</p>
        </div>

        And this using the attached POM 2:

        <a name="section 1"></a><div class="section"><h2>section 1</h2>
        <p>text 1</p>
        <ul>
        <li>list1</li>
        </ul>
        text 2
        <ul>
        <li>list1</li>
        </ul>
        text 3
        </div>

        The difference is the configured extension. You can get that from http://velocity.apache.org/site/tools/velocity-site-doxia-renderer/index.html or just drop me a mail. (I will put it into the apache repository once we got velocity 1.5 out of the door).

        Henning Schmiedehausen added a comment -

        working POM.

        Henning Schmiedehausen added a comment -

        non working POM.

        Henning Schmiedehausen added a comment -

        Ah, I forgot to mention, that I've added the DTD reference for XDOC to the source file and it is valid.

        Henning Schmiedehausen added a comment -

        It seems that maven dependency resolution fooled me. = The extension pulls in an explicit version of the doxia core (1.0-alpha-8). Once I forced it to actually use the HEAD (1.0-alpha-9-SNAPSHOT), it now renders correctly.

        Henning Schmiedehausen added a comment -

        Also fixed in unreleased 1.0-alpha-9, however that version is missing from JIRA.

        Vincent Siveton added a comment -

        Just for fun I add another test case to prove you that all is already fixed in the trunk


          People

          • Assignee:
            Unassigned
            Reporter:
            Henning Schmiedehausen
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: