Maven Doxia
  1. Maven Doxia
  2. DOXIA-437

SWF macro generates HTML tags for params without closing sign

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.2
    • Fix Version/s: 1.3
    • Component/s: Core
    • Labels:
      None
    • Patch Submitted:
      Yes
    • Number of attachments :
      1

      Description

      The SWF macro produces HTML code that does not closes the tags for param attributes.
      The following is the current code produced for this macro:

      %

      {swf|src=http://www.youtube.com/v/3W0GvjrPFj4&hl=en&fs=1|id=installingZemucan|width=640|height=480}

      <object classid="clsid27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=9,0,45,0" width="640" height="480" id="installingZemucan">
      <param name="movie" value="http://www.youtube.com/v/3W0GvjrPFj4&hl">
      <param name="quality" value="high">
      <param name="menu" value="false">
      <param name="loop" value="0">
      <param name="play" value="true">
      <param name="allowScriptAccess" value="sameDomain"><embed src="http://www.youtube.com/v/3W0GvjrPFj4&hl" width="640" height="480" loop="0" play="true" quality="high" allowScriptAccess="sameDomain" pluginspage="http://www.macromedia.com/go/getflashplayer" type="application/x-shockwave-flash" menu="false">
      </embed>
      </object>

      But the correct code should be:

      <object classid="clsid27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=9,0,45,0" width="640" height="480" id="installingZemucan">
      <param name="movie" value="http://www.youtube.com/v/3W0GvjrPFj4&hl" />
      <param name="quality" value="high" />
      <param name="menu" value="false" />
      <param name="loop" value="0" />
      <param name="play" value="true" />
      <param name="allowScriptAccess" value="sameDomain" /><embed src="http://www.youtube.com/v/3W0GvjrPFj4&hl" width="640" height="480" loop="0" play="true" quality="high" allowScriptAccess="sameDomain" pluginspage="http://www.macromedia.com/go/getflashplayer" type="application/x-shockwave-flash" menu="false">
      </embed>
      </object>

      I attached the patch that adds the final slashes for the params.

      1. SwfMacro.java.patch
        2 kB
        Andres Gomez Casanova

        Activity

        Hide
        Lukas Theussl added a comment -

        Patch applied in r1151002. Thanks!

        Show
        Lukas Theussl added a comment - Patch applied in r1151002 . Thanks!

          People

          • Assignee:
            Lukas Theussl
            Reporter:
            Andres Gomez Casanova
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: