Maven Doxia
  1. Maven Doxia
  2. DOXIA-433

Regression: Unicode characters not rendered in table cells

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.3
    • Component/s: Module - Apt
    • Labels:
      None
    • Environment:
      Maven 2.2.1, site plugin 2.3
    • Number of attachments :
      2

      Description

      After upgrading the maven-site-plugin from version 2.0.1 to 2.3, I noticed that one of my APT files in which unicode characters are used is no longer rendered correctly to HTML. More precisely, in the APT file there are several occurrences of

      \u2713

      The generated HTML file then contains

       u2713

      rather than

      I do not have a minimal example attached, but it should be easily reproducible using Maven 2.2.1 and site plugin 2.3 (you might also want to try with 2.0.1 where it works for me).

      1. t.apt
        0.4 kB
        Thorsten Möller

        Activity

        Lukas Theussl added a comment -

        I cannot reproduce this, it works here. See attached test project. Can you confirm?

        Thorsten Möller added a comment -

        Yes, I can confirm that your example works also for me. However, after checking again, I've found that the issue seems to occur only when used inside table cells. Attached you will find an example. Simply copy this file into src/site/apt and run mvn site again. Also, change the version in the POM back to 2.0.1 and then it should work.

        Lukas Theussl added a comment -

        Confirmed.

        Lukas Theussl added a comment -

        Fixed in r1137879


          People

          • Assignee:
            Lukas Theussl
            Reporter:
            Thorsten Möller
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: