DisplayTag
  1. DisplayTag
  2. DISPL-615

Excel (pre 2007 ver): too many different cell formats

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Major Major
    • Resolution: Not A Bug
    • Affects Version/s: 1.2
    • Fix Version/s: None
    • Component/s: Export
    • Labels:
      None
    • Application server:
      JBoss 4.2.3

      Description

      With a large quantiy of rows and columns excel reports:

      "Too many different cell formats"

      Then after:

      "Excel encountered an error and had to remove some formatting to avoid corrupting the workbook. Please re-check your formatting carefully"

      This affects 1.1.1 and 1.2 alike - using 3.2-FINAL POI (also tried 3.0.2-beta2 which was our previous dependency).

        Activity

        Dean Pullen added a comment -
        Sorry - this was due to a custome HSSF export view.

        It's related to constructing too many cell style objects. Instead, just one should be utilised multiple times when styling cells.

        http://www.5341.com/msg/48273.html

          People

          • Reporter:
            Dean Pullen
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: