DisplayTag
  1. DisplayTag
  2. DISPL-592

Excel export shows only sublists

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Critical Critical
    • Resolution: Not A Bug
    • Affects Version/s: 1.1.1
    • Fix Version/s: 1.2
    • Component/s: Export
    • Labels:
      None
    • Application server:
      Tomcat

      Description

      I do export my tables with the org.displaytag.export.excel.DefaultHssfExportView class. My export.amount is set to list and not page.
      Doing HTML, PDF, XML the export contains the entire list. Doing an Excel export reveals the same page as HTML. I tracked down the bug I reaized that HTML Export and Excel Export subclass TableWriterTemplate which always says in #writeTableBody "rowIterator = model.getRowIterator(false);"
      Setting to rowIterator = model.getRowIterator(model.getProperties().getExportFullList()); does not completely resolve it because HTML shows everything.

      I have attached a patch with resolves the issue but I do think that this can be done better and cleaner for both (html, xls) types.

        Activity

        Michael Osipov made changes -
        Field Original Value New Value
        Attachment DISPL-592 [ 39960 ]
        Michael Osipov added a comment -
        proposed patch
        Michael Osipov made changes -
        Attachment DISPL-592.patch [ 39961 ]
        Michael Osipov made changes -
        Attachment DISPL-592 [ 39960 ]
        Michael Osipov added a comment -
        I misunderstood the concept of the TableWriteTemplate and Default and non-Default views. Using ExcelHssfView.java instread of DefaultHssfExportView.java resolves the issue!
        Michael Osipov added a comment -
        see above
        Michael Osipov made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Not A Bug [ 6 ]
        Fix Version/s 1.2 [ 13662 ]
        Brett Porter made changes -
        Reporter Michael Osipov [ sgfan ] Michael Osipov [ michael-o ]

          People

          • Reporter:
            Michael Osipov
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: