DisplayTag
  1. DisplayTag
  2. DISPL-567

Received a JSPException in a non-predictable way

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Critical Critical
    • Resolution: Cannot Reproduce
    • Affects Version/s: 1.1.1
    • Fix Version/s: None
    • Component/s: Tag Library
    • Labels:
      None
    • Application server:
      Oracle OC4J

      Description

      Rarely I receive this exception:

      16:59:26,716 [ERROR] _unexpected._jspService(106) - Unexpected Exception JSP Page:
      javax.servlet.jsp.JspException
      at org.displaytag.render.TableWriterTemplate.writeTable(TableWriterTemplate.java(Compiled Code))
      at org.displaytag.render.HtmlTableWriter.writeTable(HtmlTableWriter.java(Inlined Compiled Code))
      at org.displaytag.tags.TableTag.writeHTMLData(TableTag.java(Compiled Code))
      at org.displaytag.tags.TableTag.doEndTag(TableTag.java(Compiled Code))
      at _consumer._consumerProfileTabPage._jspService(_consumerProfileTabPage.java(Compiled Code))
      at com.orionserver.http.OrionHttpJspPage.service(OrionHttpJspPage.java(Compiled Code))
      at oracle.jsp.runtimev2.JspPageTable.service(JspPageTable.java(Compiled Code))
      at oracle.jsp.runtimev2.JspServlet.internalService(JspServlet.java(Compiled Code))
      at oracle.jsp.runtimev2.JspServlet.service(JspServlet.java(Compiled Code))
      at javax.servlet.http.HttpServlet.service(HttpServlet.java(Compiled Code))
      at com.evermind.server.http.ServletRequestDispatcher.invoke(ServletRequestDispatcher.java(Compiled Code))
      at com.evermind.server.http.ServletRequestDispatcher.include(ServletRequestDispatcher.java(Compiled Code))
      at org.apache.taglibs.standard.tag.common.core.ImportSupport.acquireString(ImportSupport.java:314)
      at org.apache.taglibs.standard.tag.common.core.ImportSupport.doEndTag(ImportSupport.java:179)
      at _consumer._consumerFolder._jspService(_consumerFolder.java:589)
      at com.orionserver.http.OrionHttpJspPage.service(OrionHttpJspPage.java(Compiled Code))
      at oracle.jsp.runtimev2.JspPageTable.service(JspPageTable.java(Compiled Code))
      at oracle.jsp.runtimev2.JspServlet.internalService(JspServlet.java(Compiled Code))
      at oracle.jsp.runtimev2.JspServlet.service(JspServlet.java(Compiled Code))
      at javax.servlet.http.HttpServlet.service(HttpServlet.java(Compiled Code))
      at com.evermind.server.http.ServletRequestDispatcher.invoke(ServletRequestDispatcher.java(Compiled Code))
      at com.evermind.server.http.ServletRequestDispatcher.forwardInternal(ServletRequestDispatcher.java(Compiled Code))
      at com.evermind.server.http.ServletRequestDispatcher.forward(ServletRequestDispatcher.java(Compiled Code))
      at com.evermind.server.http.GetParametersRequestDispatcher.forward(GetParametersRequestDispatcher.java(Compiled Code))
      at org.apache.struts.chain.commands.servlet.PerformForward.handleAsForward(PerformForward.java(Inlined Compiled Code))
      at org.apache.struts.chain.commands.servlet.PerformForward.perform(PerformForward.java(Compiled Code))
      at org.apache.struts.chain.commands.AbstractPerformForward.execute(AbstractPerformForward.java(Compiled Code))
      at org.apache.struts.chain.commands.ActionCommandBase.execute(ActionCommandBase.java(Compiled Code))
      at org.apache.commons.chain.impl.ChainBase.execute(ChainBase.java(Compiled Code))
      at org.apache.commons.chain.generic.LookupCommand.execute(LookupCommand.java(Compiled Code))
      at org.apache.commons.chain.impl.ChainBase.execute(ChainBase.java(Compiled Code))
      at org.apache.struts.chain.ComposableRequestProcessor.process(ComposableRequestProcessor.java(Compiled Code))
      at org.apache.struts.action.ActionServlet.process(ActionServlet.java(Inlined Compiled Code))
      at org.apache.struts.action.ActionServlet.doGet(ActionServlet.java(Compiled Code))
      at javax.servlet.http.HttpServlet.service(HttpServlet.java(Compiled Code))
      at javax.servlet.http.HttpServlet.service(HttpServlet.java(Compiled Code))
      at com.evermind.server.http.ResourceFilterChain.doFilter(ResourceFilterChain.java(Compiled Code))
      at com.iveco.care.controller.security.AuthorizationFilter.doFilter(AuthorizationFilter.java(Compiled Code))
      at com.evermind.server.http.EvermindFilterChain.doFilter(EvermindFilterChain.java(Compiled Code))
      at org.springframework.web.filter.RequestContextFilter.doFilterInternal(RequestContextFilter.java(Compiled Code))
      at org.springframework.web.filter.OncePerRequestFilter.doFilter(OncePerRequestFilter.java(Compiled Code))
      at com.evermind.server.http.ServletRequestDispatcher.invoke(ServletRequestDispatcher.java(Compiled Code))
      at com.evermind.server.http.ServletRequestDispatcher.forwardInternal(ServletRequestDispatcher.java(Compiled Code))
      at com.evermind.server.http.HttpRequestHandler.processRequest(HttpRequestHandler.java(Compiled Code))
      at com.evermind.server.http.AJPRequestHandler.run(AJPRequestHandler.java(Compiled Code))
      at com.evermind.server.http.AJPRequestHandler.run(AJPRequestHandler.java(Compiled Code))
      at com.evermind.util.ReleasableResourcePooledExecutor$MyWorker.run(ReleasableResourcePooledExecutor.java(Compiled Code))
      at java.lang.Thread.run(Thread.java:570)

      I dont' know the reason of this.
      The exception remains if I update the jsp page and force its re-generation, but if I restart the application server it disappears.
      Any ideas?
      NOTE: this exception appears more frequently in a page composed by three frames self reloaded, and every frame uses the displaytag.
      Thank you.

        Activity

        fabrizio giustina added a comment -
        sorry, not enough details to help.

          People

          • Reporter:
            roberto tealdi
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: