DisplayTag
  1. DisplayTag
  2. DISPL-193

Incorrect numbered pages list in header

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 1.0
    • Fix Version/s: 1.1
    • Component/s: Tag Library
    • Labels:
      None
    • Application server:
      IBM WebSphere 5.1

      Description

      When going through a list of 236 items with 15 rows per page the header shows only the page numbers upto 15 (instead of 16). Using the "next" functionality you can go to the last page, but then no "current page" is displayed.

        Activity

        Jan van de Sandt added a comment -
        I think the problem is in the SmartListHelper class on line 285:

        startPage = Math.max(Math.min(this.currentPage - groupSize / 2, this.pageCount - groupSize), 1);

        To get the correct results this should be changed to:

        startPage = Math.max(Math.min(this.currentPage - groupSize / 2, this.pageCount - groupSize + 1), 1);
        fabrizio giustina added a comment -
        same as DISPL-213
        fixed in CVS for 1.1
        karthik added a comment -
        When going through a list of 92items with 10rows per page the header shows only the page numbers up to 9(instead of 10). Using the "next" functionality you can go to the last page, but then no "current page" is displayed.if i am using Tomcat 5.5.23 it works correctly but web logic 9.0 the same problem still exists.

          People

          • Reporter:
            Jan van de Sandt
          • Votes:
            3 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: