DisplayTag
  1. DisplayTag
  2. DISPL-191

when null value bean field is to be displayed, a previous column content is taken

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Won't Fix
    • Affects Version/s: 1.0
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Application server:
      tomcat 5.5.4

      Description

      The webmail application (http://p4u.ch) is sometimes serving empty subject lines from the DB (an error unrelated to displaytag probably due to the MySQL AESENCRYPT function).

      When displayed with display-tag, unfortunately, not the zero-length-String ("") is shown as described in http://displaytag.sourceforge.net/tagreference-displaytag-12.html#column, about the "nulls" attribute, but a value of a previous line.

      To reproduce, register for free, create a few new mails with different subject lines and save them as drafts.

      Then, create a new mail with subject line "default secure smtp for contacts (RFE 1186) und Outlook-smtp-" and save again. It will swallow the text (the above-described supposed MySQL error) and the go to drafts. Instead of seeing just an empty subject (or ". . ." we put under some conditions in this case), you will see one of your earlier subject lines repeated?

      the (struts) jsp part regarding this field reads like this:

      <display:column title='Subject to edit
      <img src="images/edit.png" style="border: 0;vertical-align:bottom;" alt="edit draft message - load for sending"
      title="edit draft message - load for sending"/>&nbsp;&nbsp;'
      sortable="true" headerClass="sortable" >
      <acronym title='<bean:write name="draftMsgList"
      property="subject" filter="true"/>' > </acronym>
      <html:link page="/editDraft.do" paramName="draftMsgList"
      paramId="msgId" paramProperty="msgId"
      title="draft message - load for sending" ><bean:write name="draftMsgList"
      property="subject" filter="true"/></html:link>
      </display:column>

        Activity

        Ralf Hauser added a comment -
        Apologies, tested further and it appears that also the reason for this behaviour is caused by the jdbc --> see http://bugs.mysql.com/8564

          People

          • Reporter:
            Ralf Hauser
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: