Continuum
  1. Continuum
  2. CONTINUUM-860

multiple email addresses delimited with commas causes AddressException

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.2
    • Component/s: Notifier - Mail
    • Labels:
      None
    • Complexity:
      Intermediate
    • Number of attachments :
      0

      Description

      Email notification fails with a "javax.mail.internet.AddressException: Illegal route-addr in string" exception when a comma-delimited list of email addresses is used.

      See the linked message for the pom.xml node for an example.
      There is a work-around, see this thread in user list

      http://mail-archives.apache.org/mod_mbox/maven-continuum-users/200609.mbox/browser

        Activity

        Emmanuel Venisse added a comment -

        Already fixed.

        Mat Schaffer added a comment -

        Where was this fixed? I'm running 1.1 and still getting:

        Caused by: javax.mail.internet.AddressException: Illegal route-addr in string ``...@...com, ...@...com, ...@...com''

        I can't find anything in the logs at http://svn.apache.org/repos/asf/maven/continuum/trunk that refers to it. I'm still hunting in http://svn.apache.org/repos/asf/maven/continuum

        Thanks!

        Paul Benedict added a comment -

        Same here. Running 1.1 and still have this error.

        Wendy Smoak added a comment -

        Reopening based on comments.

        Olivier Lamy added a comment -

        fixed in rev 647001.

        Mat Schaffer added a comment -

        I dug up the diff at http://svn.apache.org/viewvc/continuum/trunk/continuum-core/src/main/java/org/apache/maven/continuum/notification/mail/MailContinuumNotifier.java?r1=647001&r2=647000&pathrev=647001

        According to this the fix only suppresses the error by splitting on comma and sending the email to the first address on the list only. This isn't the behavior I was hoping for. Paul may have similar feelings.

        Thanks for the fix though. This at least gets rid of the error. I may open another ticket to explore support for sending multiple email addresses from a single notifier.

        Olivier Lamy added a comment -

        yes please


          People

          • Assignee:
            Olivier Lamy
            Reporter:
            Adam Hardy
          • Votes:
            3 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: